Bug 772951 - After update of eclipse-platform and eclipse-jdt to version 3.7.1-7.fc16.x86_64 java perspective stop working in eclipse IDE
After update of eclipse-platform and eclipse-jdt to version 3.7.1-7.fc16.x86_...
Status: CLOSED DUPLICATE of bug 760454
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-10 08:31 EST by Kamil Kolakowski
Modified: 2012-01-10 08:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-10 08:41:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Kolakowski 2012-01-10 08:31:01 EST
Description of problem:
After update of eclipse-platform and eclipse-jdt to version 3.7.1-7.fc16.x86_64  java perspective stop working in eclipse IDE. I can't create java project I can't run java application.

Version-Release number of selected component (if applicable):
3.7.1-7.fc16.x86_64

Steps to Reproduce:
Update eclipse-platform and eclipse-jdt plugin to version 3.7.1-7.fc16.x86_64.
Try to 1. Open Java project
       2. Run already done project


Actual results:
Not able to do Java projects in eclipse ide.

Expected results:
When I will have installed eclipse-platform & eclipse-jdt & java I will be able in eclipse create java project and I will be able to run it.

Additional info:
Ping me any time on IRC #kernel-qe nick kkolakow for more info if needed.
Comment 1 Alexander Kurtakov 2012-01-10 08:41:57 EST
This situation occurs because we had to break a packaging loop by moving a
plugin from eclipse-jdt to eclipse-platform.  Unfortunately, without invasive,
fragile workarounds, the only way to fix this is to stop Eclipse, mv
~/.eclipse{,.bak} and restart Eclipse.  Some user preferences may be
lost and plugins you manually installed  will be gone but
you should get the RPM-installed plugins back and you'll be able to re-install
anything you previously installed from within Eclipse.

We apologize for this issue and are working on a more robust solution to ensure
it never happens again.

*** This bug has been marked as a duplicate of bug 760454 ***

Note You need to log in before you can comment on or make changes to this bug.