This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 773029 - kvm.modules is missing 'modprobe vhost_net'
kvm.modules is missing 'modprobe vhost_net'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-10 12:40 EST by Daniel Berrange
Modified: 2013-01-09 19:40 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-31 15:32:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-01-10 12:40:03 EST
Description of problem:
Look at any Fedora 16 host and see that /dev/vhost-net is missing.  This is because /etc/sysconfig/modules/kvm.modules is missing 'modprobe vhost_net'

Version-Release number of selected component (if applicable):
qemu-system-x86-0.15.1-3.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1.ls -al /dev/vhost-net
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Justin M. Forbes 2012-01-27 14:40:02 EST
Added to git for F16 and F17, it will make the next package builds.
Comment 2 Daniel Berrange 2012-01-30 05:40:28 EST
The kvm.modules file is still doing a pointless  'modprobe virtio-net' which is a guest only module. 

Also bugs against stable releases shouldn't be closed when the fix is in GIT, they should be closed by Bohdi when the update is pushd to the repos.
Comment 3 Justin M. Forbes 2012-01-31 15:32:46 EST
Bodhi won't close it because I didn't add this bug number to the update, but it is in updates-testing if you want to give it karma.

Note You need to log in before you can comment on or make changes to this bug.