Bug 77305 - Kernel 2.4.18-17.7.xsmp pivotroot failed
Kernel 2.4.18-17.7.xsmp pivotroot failed
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-04 18:20 EST by ipvcor
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-05 04:29:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ipvcor 2002-11-04 18:20:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
Host specs:

Comapq Evo W6000 (workstation)
2 Intel Xeon 2.0 Ghz processors (hyper-threading disabled)
RAM: 512MB
Primary Disk: (sda) Vendor: COMPAQPC  Model: ATLAS10K3_18_WLS
Data Disks attached to a Promise Ultra100TX2 ATA controller:
hde: 390721968 sectors (200050 MB) w/2048KiB Cache, CHS=24321/255/63, UDMA(100)
hdf: 390721968 sectors (200050 MB) w/2048KiB Cache, CHS=24321/255/63, UDMA(100)

Mount info:
-----------
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2             1.0G  263M  764M  26% /
/dev/sda1              61M   32M   26M  55% /boot
/dev/hde1             186G   24G  162G  13% /home
none                  252M     0  251M   0% /dev/shm
/dev/hdf1             186G  948M  185G   1% /share
/dev/sda6             259M   33M  226M  13% /tmp
/dev/sda7             7.6G  3.6G  4.0G  47% /usr
/dev/sda5             7.0G  119M  6.8G   2% /var
-----
/dev/sda2 on / type reiserfs (rw)
none on /proc type proc (rw)
/dev/sda1 on /boot type ext3 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hde1 on /home type reiserfs (rw)
none on /dev/shm type tmpfs (rw)
/dev/hdf1 on /share type reiserfs (rw)
/dev/sda6 on /tmp type reiserfs (rw)
/dev/sda7 on /usr type reiserfs (rw)
/dev/sda5 on /var type reiserfs (rw)

/etc/modules.conf:
alias parport_lowlevel parport_pc
alias eth0 eepro100
alias scsi_hostadapter aic7xxx
alias eth1 ns83820

bootloader: lilo


System was using errata kernel 2.4.18-10smp prior to -17.xsmp.
When system boots, the following error is produced:

...
kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno = 2
mount: error 6 mounting reiserfs
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Freeing unused kernel memory: 188k freed
Kernel panic: No init found. Try passing init= option to kernel.
...


looks as if the scsi module never gets loaded, hence it can never find the
rootfs. ran mkinitrd thinking that the ram disk may have been hosed; didn't
work. passed init=/bin/sh to kernel during boot and the same error was produced.
switched to grub; still failed.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install kernel-smp.2.4.18-17.x
2. edit lilo
3. Reboot
	

Actual Results:  ...
kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno = 2
mount: error 6 mounting reiserfs
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Freeing unused kernel memory: 188k freed
Kernel panic: No init found. Try passing init= option to kernel.
...

Expected Results:  bootstrap the system...

Additional info:
Comment 1 ipvcor 2002-11-04 18:58:55 EST
uhhh.... this is weird... issued 'rpm -ivh kernel-smp-2.4.18-17.7.x.i686.rpm'
and it installed without complaining that the rpm was already installed... ????

check this out:

# rpm -q kernel-smp
kernel-smp-2.4.18-10
kernel-smp-2.4.18-17.7.x
kernel-smp-2.4.18-17.7.x
kernel-smp-2.4.18-17.7.x

wtf???
Comment 2 Arjan van de Ven 2002-11-05 04:29:43 EST
hummm... this is funky.
rpm -e --allmatches kernel-smp-2.4.18-17.7.x
will remove all of them and then install only 1.
Once that doesn't work please check the boot log to see if there's ANY sign of
scsi driver activity..
Comment 3 ipvcor 2002-11-05 15:42:23 EST
removed all instances of -17.xsmp and reinstalled. booted without a problem!
weird...

out of curiosity, the first time i installed -17.xsmp, i was running a homemade
kernel with the scsi driver built statically in the kernel (2.4.19). would this
by chance have any effect on the installation of the errata kernel? am thinking
that since the scsi driver was commented out in /etc/modules.conf while i was
running my own kernel, that the install process for the errata kernel somehow
'skipped' the scsi driver (it was uncommented in my previous attempts to boot
the errata kernel). does this sound reasonable or should i just leave
well-enough alone? ;)

thanks again for your help!

Note You need to log in before you can comment on or make changes to this bug.