Bug 773216 - RFE: abrt python plugin should work for non-package files as well
Summary: RFE: abrt python plugin should work for non-package files as well
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt   
(Show other bugs)
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-11 09:54 UTC by Rakesh Pandit
Modified: 2012-06-15 11:17 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 11:17:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rakesh Pandit 2012-01-11 09:54:44 UTC
I developing a code and what abrt to catch unhandled exceptions. Right now it doesn't create the pyhook directory if file which raises exception doesn't belong to a package.

Messages in log:
Jan 11 14:30:32 locahost abrtd: New client connected
Jan 11 14:30:32 locahost abrtd: Directory 'pyhook-2012-01-11-14:30:32-6841' creation detected
Jan 11 14:30:32 locahost abrt-server[6842]: Saved Python crash dump of pid 6841 to /var/spool/abrt/pyhook-2012-01-11-14:30:32-6841
Jan 11 14:30:32 locahost abrtd: Executable 'abidiff_daemon.py' doesn't belong to any package
Jan 11 14:30:32 locahost abrtd: 'post-create' on '/var/spool/abrt/pyhook-2012-01-11-14:30:32-6841' exited with 1
Jan 11 14:30:32 locahost abrtd: Corrupted or bad directory /var/spool/abrt/pyhook-2012-01-11-14:30:32-6841, deleting


One can keep this option by default off. Those folks who want to use it can switch it on.

Regards,

Comment 1 Rakesh Pandit 2012-01-11 09:56:25 UTC
In case it is already made to work with no package files but here the reason for exit is different, ping me and I will pass in more information so that this can be debugged.

I see post-create exited with 1.

Regards,

Comment 2 Jiri Moskovcak 2012-06-15 11:17:03 UTC
You should be able to enable it in config file: /etc/abrt/abrt-action-save-package-data.conf search for line:

ProcessUnpackaged = no

and change it to:

ProcessUnpackaged = yes


Note You need to log in before you can comment on or make changes to this bug.