This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 773380 - Yesterdays update to 3.7.1-7 broke most functionality (JDT, Subclipse, etc)
Yesterdays update to 3.7.1-7 broke most functionality (JDT, Subclipse, etc)
Status: CLOSED DUPLICATE of bug 760454
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
16
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-11 12:34 EST by Charles Butterfield
Modified: 2012-01-11 17:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-11 12:51:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Butterfield 2012-01-11 12:34:52 EST
Description of problem:  Yesterday I did a routine yum update which updated my eclipse components (platform, swt, rcp, jdt) from 3.7.1-4 to 3.7.1-7.  This caused major breakage - lots of error messages at startup, missing perspectives (Java), loss,   I didn't capture all of the details at the time, but see steps to reproduce below.


Version-Release number of selected component (if applicable): 3.7.1-7


How reproducible: Totally


Steps to Reproduce:
1. yum erase eclipse*
2. yum install eclipse-jdt
3. run eclipse
4. New Project does not have a Java project as an option
  
Actual results:
No "Java Project" support

Expected results:
Naturally we would expect "Java Project"

Additional info:
Comment 1 Andrew Overholt 2012-01-11 12:51:47 EST
This situation occurs because we had to break a packaging loop by moving a plugin from eclipse-jdt to eclipse-platform. Unfortunately, without invasive, fragile workarounds, the only way to fix this is to stop Eclipse, mv ~/.eclipse{,.bak2011-12-21} and restart Eclipse. Some user preferences may be lost and plugins you manually installed (qt, it sounds like) will be gone but you should get the RPM-installed plugins back and you'll be able to re-install anything you previously installed from within Eclipse.

We apologize for this issue and are working on a more robust solution to ensure it never happens again.

*** This bug has been marked as a duplicate of bug 760454 ***
Comment 2 Charles Butterfield 2012-01-11 17:01:08 EST
Yes, nuking my .eclipse tree did the trick.
Thanks!
-- Charlie

Note You need to log in before you can comment on or make changes to this bug.