This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 773438 - [abrt] kernel: irq 17: nobody cared (try booting with the "irqpoll" option) ASM108x
[abrt] kernel: irq 17: nobody cared (try booting with the "irqpoll" option) A...
Status: CLOSED DUPLICATE of bug 755956
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:427c0230337ba3a9c9a2e2454dc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-11 15:15 EST by gcndavidmn
Modified: 2012-03-05 16:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 16:59:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gcndavidmn 2012-01-11 15:15:21 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.1.7-1.fc16.x86_64 root=UUID=98caa939-736b-4a13-abe8-f0385c6a759a ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb KEYTABLE=uk rd.luks=0 LANG=en_US.UTF-8
kernel:         3.1.7-1.fc16.x86_64
reason:         irq 17: nobody cared (try booting with the "irqpoll" option)
time:           Tue 10 Jan 2012 02:01:43 AM GMT

backtrace:
:irq 17: nobody cared (try booting with the "irqpoll" option)
:Pid: 0, comm: swapper Not tainted 3.1.7-1.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff810dc8bd>] __report_bad_irq+0x3d/0xe0
: [<ffffffff810dcb7d>] note_interrupt+0x16d/0x220
: [<ffffffff8101a569>] ? sched_clock+0x9/0x10
: [<ffffffff810da939>] handle_irq_event_percpu+0xa9/0x220
: [<ffffffff810daaf4>] handle_irq_event+0x44/0x70
: [<ffffffff810dd4df>] handle_fasteoi_irq+0x5f/0xf0
: [<ffffffff810151e9>] handle_irq+0x49/0xa0
: [<ffffffff815df89a>] do_IRQ+0x5a/0xe0
: [<ffffffff815d532e>] common_interrupt+0x6e/0x6e
: <EOI>  [<ffffffff8130569b>] ? intel_idle+0xcb/0x120
: [<ffffffff8130567d>] ? intel_idle+0xad/0x120
: [<ffffffff814842a6>] cpuidle_idle_call+0xc6/0x280
: [<ffffffff81012225>] cpu_idle+0xc5/0x120
: [<ffffffff815af26e>] rest_init+0x72/0x74
: [<ffffffff81b7ec0a>] start_kernel+0x3b5/0x3c0
: [<ffffffff81b7e347>] x86_64_start_reservations+0x132/0x136
: [<ffffffff81b7e140>] ? early_idt_handlers+0x140/0x140
: [<ffffffff81b7e44d>] x86_64_start_kernel+0x102/0x111

smolt_data:
:
:
:General
:=================================
:UUID: 52173e96-c353-4567-9bc5-876e0d4c45cf
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6621.10
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 3301
:System Memory: 5951
:System Swap: 3608
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.1.7-1.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:256:4163:33869) pci, None, HOST/PCI, P8P67 Deluxe Motherboard
:(32902:257:4163:33869) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(4358:12356:4163:33278) pci, firewire_ohci, FIREWIRE, M4A series motherboard
:(32902:7202:4163:33869) pci, i801_smbus, SERIAL, P8P67 Deluxe Motherboard
:(32902:7170:4163:33869) pci, ahci, STORAGE, P8P67 Deluxe Motherboard
:(32902:7238:4163:33869) pci, None, PCI/ISA, P8P67 Deluxe Motherboard
:(32902:5379:4163:33948) pci, e1000e, ETHERNET, P8P67 Deluxe Motherboard
:(6987:37234:4163:33911) pci, ahci, STORAGE, N/A
:(32902:7213:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7206:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7226:4163:33869) pci, None, SIMPLE, P8P67 Deluxe Motherboard
:(6945:4224:6945:4224) pci, None, PCI/PCI, N/A
:(4147:404:4163:33811) pci, xhci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7188:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7190:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:9294:4163:33869) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7198:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 8
:(32902:7192:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:4163:33897) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(4147:404:4163:33811) pci, xhci_hcd, USB, P8P67 Deluxe Motherboard
:(4318:3051:6860:17931) pci, snd_hda_intel, MULTIMEDIA, GF104 High Definition Audio Controller
:(4318:3618:6860:17931) pci, nouveau, VIDEO, GF104 [GeForce GTX 460]
:(6523:9058:4163:33888) pci, ahci, STORAGE, P8P67 Deluxe Motherboard
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 14474557 13175653 13028655 3678208 3538349 3538349
:/dev/sdb1 /home ext4 4096 4096 480714588 189668857 165249957 122101760 121893550 121893550
:/dev/sde1 WITHHELD fuseblk 4096 4096 488378000 315433098 315433098 1262027304 1261765153 1261765153
:/dev/sdd1 WITHHELD ext4 4096 4096 240358018 17280046 5070546 61054976 60873834 60873834
:
Comment 1 John Gotts 2012-01-12 14:06:59 EST
Any luck by adding pci=nocrs to the boot options?
Comment 2 gcndavidmn 2012-01-12 14:12:25 EST
(In reply to comment #1)
> Any luck by adding pci=nocrs to the boot options?

What exactly should I do so I don't balls it up?
Comment 3 John Gotts 2012-01-12 14:28:28 EST
Don't worry about messing things up. Just edit the command line options in GRUB and add pci=nocrs. It won't harm anything, and it may do nothing, but it might help.
Comment 4 Josh Boyer 2012-01-24 14:12:10 EST
Can you attach the output of dmesg and /proc/interrupts?  Also, do you see this on the 3.1.9 or 3.2.1 kernel updates?
Comment 5 Josh Boyer 2012-02-02 15:38:35 EST
Your motherboard is using the ASM108x PCI bridge.  There is a problem identified with this particular chip upstream that might be causing this issue:

http://thread.gmane.org/gmane.linux.kernel/1245767
Comment 6 Josh Boyer 2012-03-05 16:57:42 EST
We're going to consolidate all of these bugs with the impacted hardware into a single bug.  The latest F15 and F16 kernel updates that should hit the mirrors soon have a patch to at least fall back to the irqpoll method when this happens.  Hopefully it results in a bit better experience for you.
Comment 7 Josh Boyer 2012-03-05 16:59:35 EST

*** This bug has been marked as a duplicate of bug 755956 ***

Note You need to log in before you can comment on or make changes to this bug.