Bug 773466 - template xml validation results in mis-rendered page
template xml validation results in mis-rendered page
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Provaznik
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-11 16:40 EST by Dave Johnson
Modified: 2012-05-15 17:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 17:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss (42.86 KB, image/png)
2012-01-11 16:40 EST, Dave Johnson
no flags Details
xml_validated (215.30 KB, image/png)
2012-01-19 03:35 EST, Shveta
no flags Details

  None (edit)
Description Dave Johnson 2012-01-11 16:40:12 EST
Created attachment 552245 [details]
ss

Description of problem:
=============================
xml validation errors result in an error on a mis-rendered page (see screenshot).  This occurs when I start with good xml and remove a end tag like <os> , </name> , etc.


Version-Release number of selected component (if applicable):
===================================================================
aeolus-conductor-0.8.0-5.el6.noarch
Comment 1 wes hayutin 2012-01-12 11:52:00 EST
adding to sprint tracker
Comment 2 Angus Thomas 2012-01-12 12:17:04 EST
This should use the flash error mechanism to report the error, without leaving the view that contains the edited XML.
Comment 3 Jan Provaznik 2012-01-13 09:17:18 EST
patch is on the list: https://fedorahosted.org/pipermail/aeolus-devel/2012-January/008072.html
Comment 4 Jan Provaznik 2012-01-18 03:25:44 EST
pushed in commits:
94cedf1c8c88f9f931a450401d26e8eb28d8acc4
378d2641538b6638bea60d0e1d4f2afe7f99e717
Comment 5 Steve Linabery 2012-01-18 16:01:48 EST
aeolus-conductor-0.8.0-8.el6.src.rpm
3d2f075aebce41f8ce74bcee07fe52b97ae0ad92
7f0eb07cbb7efaa48e620f09610b19e3becfeba4
Comment 6 Shveta 2012-01-19 03:35:27 EST
Created attachment 556208 [details]
xml_validated
Comment 7 Shveta 2012-01-19 03:36:21 EST
Verified in
rpm -qa|grep aeolus
aeolus-conductor-0.8.0-8.el6.noarch
aeolus-conductor-daemons-0.8.0-8.el6.noarch
rubygem-aeolus-image-0.3.0-3.el6.noarch
rubygem-aeolus-cli-0.3.0-4.el6.noarch
aeolus-all-0.8.0-8.el6.noarch
aeolus-configure-2.5.0-5.el6.noarch
aeolus-conductor-doc-0.8.0-8.el6.noarch
Comment 9 errata-xmlrpc 2012-05-15 17:39:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.