Bug 77347 - USB shuts off intermittantly after upgrade to 8.0.
USB shuts off intermittantly after upgrade to 8.0.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-05 11:59 EST by Derek Price
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-04 12:25:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
`grep -i usb /var/log/messages' (27.04 KB, text/plain)
2002-11-05 12:01 EST, Derek Price
no flags Details

  None (edit)
Description Derek Price 2002-11-05 11:59:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
USB always shuts off after the system has been up for a day or two.  Sometimes
the mouse shuts off by itself too.  Unplugging the mouse and plugging it back in
reenables it, but when everything shuts off, no amount of unplugging and
replugging seems to fix the problem, forcing me to ssh in to reboot the machine.
 This restores the USB devices for another day or two.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH Linux 8.0 on a machine with USB devices.
2.Wait
3.
	

Actual Results:  The USB devices shut off.

Expected Results:  The USB devices should have continued working indefinately.

Additional info:

I will attach a copy of `grep -i usb /var/log/messages' for the last boot/reboot
cycle.

It is probably safe to ignore the entries where all four devices disconnect and
reconnect properly.  I have a Keyboard/USB switch attached to share the hub,
keyboard, mouse, and monitor between two machines.

Just before the reboot, the log messages state that devices won't accept new
addresses.
Comment 1 Derek Price 2002-11-05 12:01:22 EST
Created attachment 83706 [details]
`grep -i usb /var/log/messages'
Comment 2 Pete Zaitcev 2003-06-04 00:18:22 EDT
Oh my, a forgotten bug. That's embarrasing.

Derek, can you re-try it with the 2.4.20-18.7 kernel?
If you gave up on it, I understand. Sorry.
Comment 3 Derek Price 2003-06-04 09:16:22 EDT
I'm using 2.4.18-13.8 now and I haven't seen the problem in awhile.  I can't
recall which upgrade fixed it exactly.

After the bus shutdown problem ceased, I think, I did discover a cable problem
with my mouse which would cause it to shut off once in awhile when the cable was
jiggled and have since replaced it, though I don't think that should have shut
down the whole bus in such a way that a reboot without shaking cables fixed it?

Anyway, thanks for getting back to this.  If I see the problem again, I'll try
and add more data, but it certainly isn't happening every other day anymore.
Comment 4 Pete Zaitcev 2003-06-04 12:25:34 EDT
Well, I'll resolve it to errata then.
Also, 2.4.20-18[.8] did have fixes to usb, but if -13 works for you, great.

Note You need to log in before you can comment on or make changes to this bug.