Bug 773527 - [ALL LANG] [RHSM CLI] redeem module Error message "'ascii' codec can't encode characters in position.." .
[ALL LANG] [RHSM CLI] redeem module Error message "'ascii' codec can't encode...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.8
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: William Poteat
IDM QE LIST
: i18n
Depends On:
Blocks: 807971 771748
  Show dependency treegraph
 
Reported: 2012-01-12 02:05 EST by Lijun Li
Modified: 2013-01-07 22:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The logging of unicode strings. Consequence: A traceback would be printed to the console. Fix: Properly handling logging messages as unicode. Result: No tracebacks are produced.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:48:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ascii' codec can't encode characters in position error message (15.29 KB, image/png)
2012-01-12 02:08 EST, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-01-12 02:05:29 EST
Description of problem:
Error message "'ascii' codec can't encode characters in position.." .

Version-Release number of selected component (if applicable):
subscription-manager-0.98.10-1.el5

How reproducible:
100%

Steps to Reproduce:
1. Install rhel5.8 snapshot-3 OS build via
http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL5.8-Server-20120105.0/5/i386/os/

2. (Run the command when the system IS registered)

$ sudo subscription-manager redeem --email=EMAIL

  
Actual results:
Error message "'ascii' codec can't encode characters in position..".

Expected results:
Should no error message "'ascii' codec can't encode characters in position.." .

Additional info:
Comment 1 Lijun Li 2012-01-12 02:08:24 EST
Created attachment 552324 [details]
ascii' codec can't encode characters in position error message
Comment 4 RHEL Product and Program Management 2012-04-02 06:20:10 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 J.C. Molet 2012-06-25 08:04:50 EDT
Testing with versions:
python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-1.0.4-1.git.20.0466bff.el5


[root@jmolet-vm0 ~]# subscription-manager clean
All local data removed
[root@jmolet-vm0 ~]# subscription-manager register --username stage_test_12
Password: 
The system has been registered with id: d2065fe6-91ea-4419-89d9-fa0783708dcc 
[root@jmolet-vm0 ~]# subscription-manager redeem --email=test@redhat.com
The system is unable to redeem the requested subscription: Not Specified
[root@jmolet-vm0 ~]# LANG=zh_TW.UTF8 subscription-manager redeem --email=test@redhat.com
The system is unable to redeem the requested subscription: Not Specified
[root@jmolet-vm0 ~]# LANG=zh_CN.UTF8 subscription-manager redeem --email=test@redhat.com
The system is unable to redeem the requested subscription: Not Specified


Cannot reproduce as of above versions using the same steps.  We now get the appropriate error message even with other LANG's specified.  Marking VERIFIED.
Comment 9 errata-xmlrpc 2013-01-07 22:48:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.