Bug 773530 - [4e40a7e48757feedc959c7982acf05c73f739a15]: df shows negative values for mount if limit-usage set is less than disk space used
[4e40a7e48757feedc959c7982acf05c73f739a15]: df shows negative values for mou...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.3-beta
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Raghavendra G
Saurabh
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-01-12 02:16 EST by Rahul C S
Modified: 2016-01-19 01:10 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: release3.3(commit b86436da7e0de47282c46cd14989e4cbaad0501d)
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul C S 2012-01-12 02:16:01 EST
Description of problem:
root@Dagobah:~# gluster volume quota vol limit-usage / 100MB
limit set on /
root@Dagobah:~# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda5              46G   25G   20G  57% /
none                  1.9G  732K  1.9G   1% /dev
none                  1.9G  2.9M  1.9G   1% /dev/shm
none                  1.9G  396K  1.9G   1% /var/run
none                  1.9G     0  1.9G   0% /var/lock
/dev/sda9              37G   24G   13G  66% /misc
/dev/sda6              38G   27G   11G  72% /muzic
/dev/sda8              38G   36G  1.4G  97% /myst
/dev/sda7              94G   67G   27G  72% /tent
dagobah:vol           100M  -43G   43G   -  /root/mount
dagobah:vol           100M  -43G   43G   -  /root/newmount
root@Dagobah:~# gluster volume quota vol list
	path		  limit_set	     size
-------------------------------------------------------------------------------
/                           100MB            208.1MB

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Raghavendra G 2012-03-20 00:48:53 EDT
Did you set the limit on a directory already containing data? If it is so, this is not a bug, since quota is enforced only for operations done after a limit is set. If not, please provide exact test cases.

regards,
Raghavendra.
Comment 2 Raghavendra G 2012-03-20 00:50:49 EDT
Sorry, I misread the bug. But anyways, answers to the questions asked are welcome.
Comment 3 Raghavendra G 2012-04-08 10:28:18 EDT
*** Bug 773528 has been marked as a duplicate of this bug. ***
Comment 5 Anand Avati 2012-04-13 01:19:04 EDT
CHANGE: http://review.gluster.com/3102 (features/quota: don't adjust statfs buffer if size used is already greater than available limit.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 6 Saurabh 2012-05-24 05:18:15 EDT
negative values are not seen anymore

Note You need to log in before you can comment on or make changes to this bug.