Bug 773557 - [abrt] libreoffice-core-3.4.4.2-6.fc16: stoc_bootstrap::smgr_getImplementationName (SIGSEGV), [ntfs ?]
[abrt] libreoffice-core-3.4.4.2-6.fc16: stoc_bootstrap::smgr_getImplementatio...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
abrt_hash:f3f20520f130f29b35f8ee79073...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-12 04:17 EST by Gawain Lynch
Modified: 2012-02-29 03:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 03:14:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (5.63 KB, text/plain)
2012-01-12 04:17 EST, Gawain Lynch
no flags Details
File: maps (20.99 KB, text/plain)
2012-01-12 04:17 EST, Gawain Lynch
no flags Details
File: backtrace (20.10 KB, text/plain)
2012-01-12 04:17 EST, Gawain Lynch
no flags Details

  None (edit)
Description Gawain Lynch 2012-01-12 04:17:01 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///tmp/TaylorEB_Abstract.odt --splash-pipe=7
comment:        Problem occurs on launch.  Nothing outputted to console on lauching via command line either.
crash_function: stoc_bootstrap::smgr_getImplementationName
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.1.7-1.fc16.x86_64
pid:            10064
pwd:            /media/Win7_NTFS/Users/Gawain
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           Thu 12 Jan 2012 03:21:37 PM EST
uid:            1000
username:       gawain

backtrace:      Text file, 20579 bytes
dso_list:       Text file, 5763 bytes
maps:           Text file, 21491 bytes

environ:
:XDG_VTNR=1
:XSUNTRANSPORT=shmem
:XDG_SESSION_ID=2
:HOSTNAME=legolas.felicity-group.com
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=10051
:GPG_AGENT_INFO=/tmp/keyring-NhJ22h/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=4cf20f103deb7e12519457d20000000a-1326324733.146714-1951960427
:XRE_PROFILE_NAME=
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-NhJ22h
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:XRE_IMPORT_PROFILES=
:MOZILLA_FIVE_HOME=/usr/lib64/firefox
:IMSETTINGS_MODULE=none
:USER=gawain
:XRE_PROFILE_LOCAL_PATH=
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64:/usr/lib64/firefox:/usr/lib64/firefox/plugins:/usr/lib64/firefox
:XRE_START_OFFLINE=
:SSH_AUTH_SOCK=/tmp/keyring-NhJ22h/ssh
:LIBPATH=/usr/lib64/firefox:/usr/lib64/firefox
:USERNAME=gawain
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1427,unix/unix:/tmp/.ICE-unix/1427
:GNOME_DISABLE_CRASH_DIALOG=1
:MOZ_APP_LAUNCHER=/usr/bin/firefox
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MOZ_PLUGIN_PATH=/usr/lib64/mozilla/plugins:/usr/lib64/firefox/plugins
:MAIL=/var/spool/mail/gawain
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/gawain/.local/bin:/home/gawain/bin
:DESKTOP_SESSION=gnome
:FONTCONFIG_PATH=/etc/fonts:/usr/lib64/firefox/res/Xft
:QT_IM_MODULE=xim
:PWD=/home/gawain
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1419
:LANG=en_US.UTF-8
:XRE_PROFILE_PATH=
:XSUNSMESIZE=512
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/gawain
:XDG_SEAT=seat0
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:DYLD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:LOGNAME=gawain
:CVS_RSH=ssh
:MOZ_GRE_CONF=/etc/gre.d/gre64.conf
:MOZ_LAUNCHED_CHILD=
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-hr5Ix3ea58,guid=99737b96458c5374acbf5fce0000003b
:NO_EM_RESTART=
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:SHLIB_PATH=/usr/lib64/firefox:/usr/lib64/firefox
:MOZ_CRASHREPORTER_RESTART_ARG_1=
:WINDOWPATH=1
:MOZ_CRASHREPORTER_RESTART_ARG_0=/usr/lib64/firefox/firefox
:XRE_BINARY_PATH=
:XDG_RUNTIME_DIR=/run/user/gawain
:DISPLAY=:0
:'MOZ_CRASHREPORTER_DATA_DIRECTORY=/home/gawain/.mozilla/firefox/Crash Reports'
:XUL_APP_FILE=
:NO_AT_BRIDGE=1
:XAUTHORITY=/var/run/gdm/auth-for-gawain-HrSybs/database

var_log_messages:
:Jan 12 15:21:37 legolas kernel: [17401.878402] soffice.bin[10064]: segfault at 7fbc9baa6090 ip 00007fbc9bab5310 sp 00007fffd79e8fb8 error 7 in bootstrap.uno.so[7fbc9ba7c000+b8000]
:Jan 12 15:21:37 legolas abrt[10066]: Saved core dump of pid 10064 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-01-12-15:21:37-10064 (11907072 bytes)
Comment 1 Gawain Lynch 2012-01-12 04:17:06 EST
Created attachment 552350 [details]
File: dso_list
Comment 2 Gawain Lynch 2012-01-12 04:17:10 EST
Created attachment 552351 [details]
File: maps
Comment 3 Gawain Lynch 2012-01-12 04:17:12 EST
Created attachment 552352 [details]
File: backtrace
Comment 4 Caolan McNamara 2012-01-12 06:06:08 EST
This crashes for you on every launch ?, or just with a specific file. Sort of looks to me like the libs themselves are busted and there's something wrong with the install.

a
yum erase libreoffice-ure 
yum install libreoffice
might help there to remove all the libreoffice stuff and install the default libreoffice packages again
Comment 5 Caolan McNamara 2012-02-28 12:09:13 EST
hmm, iniDir = "file:///media/Win7_NTFS/Users/Gawain", that's a little unusual. Perhaps that's the trigger, having a ntfs mounted home dir.

What way is that dir mounted ?, i.e. output of
mount | grep Gawain

caolanm->sbergman: any thoughts about the above backtrace given the possibility of a iniDir on a foreign filesystem ?
Comment 6 Gawain Lynch 2012-02-28 20:37:49 EST
Oh my, sorry I forgot about this.  I'm in Haiti and overloaded with work.

OK:
* The home directory is on an NTFS partition
* Originally /home/gawain was a symlink to the NTFS mount (/home was ext4)
* /home/gawain is now a bind mount of /media/Win7_NTFS/Users/Gawain
* The crashes would start consistently happening after a reinstall and 2 or 3 restarts of the OS
* `rpm -V` reported no problems
* libreoffice has been stable now for a couple of weeks, probably due to one of the updates

It is worth noting that I am using an ASUS ZenBook and there were multiple "wierdnesses" that disappeared circa kernel-3.2.

However, I am no longer seeing the problem and if you require nothing more in the way of information from me I am happy to close this BZ.
Comment 7 Stephan Bergmann 2012-02-29 03:14:38 EST
"Wierdnesses" probably describes what one sees here best.  From the attached bt, it would look like SEGVing on push %rbx upon entry to stoc_bootstrap::smgr_getImplementationName, i.e., the stack pointer %rsp pointing outside allocated memory.  But there is no reason why cppu::component_getFactoryHelper should call with a broken %rsp (and for frame #1 the stack is apparently still OK, as gdb could otherwise not display its locals).  And the failing code path seems completely unrelated to whether iniDir points to an NTFS mount.  So closing this.

Note You need to log in before you can comment on or make changes to this bug.