This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 773581 - Eclipse can't find plugins (CDT, pydev, vrapper, ...) since the last yum update
Eclipse can't find plugins (CDT, pydev, vrapper, ...) since the last yum update
Status: CLOSED DUPLICATE of bug 760454
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-12 05:22 EST by Martin Preisler
Modified: 2012-01-12 08:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-12 08:37:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Preisler 2012-01-12 05:22:08 EST
Description of problem:
C/C++ perspective, PyDev perspective and various other features provided by Eclipse plugins were working fine prior to the following update:

Removed:
  kernel.x86_64 0:3.1.5-2.fc16        kernel-devel.x86_64 0:3.1.5-2.fc16       

Installed:
  kernel.x86_64 0:3.1.7-1.fc16        kernel-devel.x86_64 0:3.1.7-1.fc16       

Dependency Installed:
  apache-commons-collections.noarch 0:3.2.1-11.fc16                             
  apache-commons-dbcp.noarch 0:1.4-7.fc16                                       
  apache-commons-pool.noarch 0:1.5.6-1.fc16                                     
  ecj.x86_64 1:3.4.2-9.fc15                                                     
  tomcat-el-2.2-api.noarch 0:7.0.23-1.fc16                                      
  tomcat-jsp-2.2-api.noarch 0:7.0.23-1.fc16                                     
  tomcat-lib.noarch 0:7.0.23-1.fc16                                             
  tomcat-servlet-3.0-api.noarch 0:7.0.23-1.fc16                                 

Updated:
  duplicity.x86_64 0:0.6.17-1.fc16                                              
  eclipse-jdt.x86_64 1:3.7.1-7.fc16                                             
  eclipse-pde.x86_64 1:3.7.1-7.fc16                                             
  eclipse-platform.x86_64 1:3.7.1-7.fc16                                        
  eclipse-rcp.x86_64 1:3.7.1-7.fc16                                             
  eclipse-swt.x86_64 1:3.7.1-7.fc16                                             
  gnome-games.x86_64 1:3.2.1-3.fc16                                             
  hplip-common.x86_64 0:3.11.12-1.fc16                                          
  hplip-libs.x86_64 0:3.11.12-1.fc16                                            
  ibus.x86_64 0:1.4.0-17.fc16                                                   
  ibus-gtk2.x86_64 0:1.4.0-17.fc16                                              
  ibus-gtk3.x86_64 0:1.4.0-17.fc16                                              
  ibus-libs.x86_64 0:1.4.0-17.fc16                                              
  iftop.x86_64 0:1.0-0.1.pre2.fc16                                              
  kernel-headers.x86_64 0:3.1.7-1.fc16                                          
  kernel-tools.x86_64 0:3.1.7-1.fc16                                            
  libXi.i686 0:1.4.5-1.fc16                                                     
  libXi.x86_64 0:1.4.5-1.fc16                                                   
  libXi-debuginfo.x86_64 0:1.4.5-1.fc16                                         
  libXi-devel.x86_64 0:1.4.5-1.fc16                                             
  libcddb.x86_64 0:1.3.2-7.fc16                                                 
  libmcpp.x86_64 0:2.7.2-6.fc16                                                 
  libpurple.x86_64 0:2.10.1-1.fc16                                              
  libreport.x86_64 0:2.0.8-4.fc16                                               
  libreport-filesystem.x86_64 0:2.0.8-4.fc16                                    
  libreport-gtk.x86_64 0:2.0.8-4.fc16                                           
  libreport-newt.x86_64 0:2.0.8-4.fc16                                          
  libreport-plugin-bodhi.x86_64 0:2.0.8-4.fc16                                  
  libreport-plugin-bugzilla.x86_64 0:2.0.8-4.fc16                               
  libreport-plugin-kerneloops.x86_64 0:2.0.8-4.fc16                             
  libreport-plugin-logger.x86_64 0:2.0.8-4.fc16                                 
  libreport-plugin-reportuploader.x86_64 0:2.0.8-4.fc16                         
  libreport-python.x86_64 0:2.0.8-4.fc16                                        
  libsane-hpaio.x86_64 0:3.11.12-1.fc16                                         
  libvirt.x86_64 0:0.9.6-4.fc16                                                 
  libvirt-client.x86_64 0:0.9.6-4.fc16                                          
  libvirt-python.x86_64 0:0.9.6-4.fc16                                          
  libvncserver.x86_64 0:0.9.8.2-2.fc16                                          
  mcpp.x86_64 0:2.7.2-6.fc16                                                    
  nss.i686 0:3.13.1-10.fc16                                                     
  nss.x86_64 0:3.13.1-10.fc16                                                   
  nss-softokn.i686 0:3.13.1-15.fc16                                             
  nss-softokn.x86_64 0:3.13.1-15.fc16                                           
  nss-softokn-freebl.i686 0:3.13.1-15.fc16                                      
  nss-softokn-freebl.x86_64 0:3.13.1-15.fc16                                    
  nss-sysinit.x86_64 0:3.13.1-10.fc16                                           
  openssl.i686 0:1.0.0f-1.fc16                                                  
  openssl.x86_64 0:1.0.0f-1.fc16                                                
  openssl-devel.x86_64 0:1.0.0f-1.fc16                                          
  papyon.noarch 0:0.5.6-1.fc16                                                  
  pcre.x86_64 0:8.12-7.fc16                                                     
  pcre-devel.x86_64 0:8.12-7.fc16                                               
  perl.x86_64 4:5.14.2-193.fc16                                                 
  perl-CPAN.noarch 0:1.9600.01-193.fc16                                         
  perl-Digest-SHA.x86_64 1:5.61-193.fc16                                        
  perl-ExtUtils-MakeMaker.noarch 0:6.57.5-193.fc16                              
  perl-ExtUtils-ParseXS.noarch 1:2.2210-193.fc16                                
  perl-HTTP-Tiny.noarch 0:0.012-193.fc16                                        
  perl-Module-Pluggable.noarch 1:3.90-193.fc16                                  
  perl-PathTools.x86_64 0:3.33-193.fc16                                         
  perl-Pod-Escapes.noarch 1:1.04-193.fc16                                       
  perl-Pod-Simple.noarch 1:3.16-193.fc16                                        
  perl-Scalar-List-Utils.x86_64 0:1.23-193.fc16                                 
  perl-Test-Harness.noarch 0:3.23-193.fc16                                      
  perl-devel.x86_64 4:5.14.2-193.fc16                                           
  perl-libs.x86_64 4:5.14.2-193.fc16                                            
  perl-macros.x86_64 4:5.14.2-193.fc16                                          
  perl-threads.x86_64 0:1.83-193.fc16                                           
  perl-threads-shared.x86_64 0:1.37-193.fc16                                    
  phonon.x86_64 0:4.6.0-1.fc16                                                  
  pidgin.x86_64 0:2.10.1-1.fc16                                                 
  python-bunch.noarch 0:1.0.1-1.fc16                                            
  qtwebkit.x86_64 0:2.2.1-2.fc16                                                
  qtwebkit-devel.x86_64 0:2.2.1-2.fc16                                          
  ruby-libs.x86_64 0:1.8.7.357-1.fc16                                           
  scribus.x86_64 0:1.4.0-2.fc16                                                 
  scribus-doc.noarch 0:1.4.0-2.fc16                                             
  selinux-policy.noarch 0:3.10.0-71.fc16                                        
  setup.noarch 0:2.8.36-3.fc16                                                  
  spice-server.x86_64 0:0.10.0-1.fc16                                           
  wine.x86_64 0:1.3.36-1.fc16                                                   
  wine-alsa.i686 0:1.3.36-1.fc16                                                
  wine-alsa.x86_64 0:1.3.36-1.fc16                                              
  wine-capi.i686 0:1.3.36-1.fc16                                                
  wine-capi.x86_64 0:1.3.36-1.fc16                                              
  wine-cms.i686 0:1.3.36-1.fc16                                                 
  wine-cms.x86_64 0:1.3.36-1.fc16                                               
  wine-common.noarch 0:1.3.36-1.fc16                                            
  wine-core.i686 0:1.3.36-1.fc16                                                
  wine-core.x86_64 0:1.3.36-1.fc16                                              
  wine-courier-fonts.noarch 0:1.3.36-1.fc16                                     
  wine-desktop.noarch 0:1.3.36-1.fc16                                           
  wine-fonts.noarch 0:1.3.36-1.fc16                                             
  wine-ldap.i686 0:1.3.36-1.fc16                                                
  wine-ldap.x86_64 0:1.3.36-1.fc16                                              
  wine-marlett-fonts.noarch 0:1.3.36-1.fc16                                     
  wine-ms-sans-serif-fonts.noarch 0:1.3.36-1.fc16                               
  wine-openal.i686 0:1.3.36-1.fc16                                              
  wine-openal.x86_64 0:1.3.36-1.fc16                                            
  wine-pulseaudio.i686 0:1.3.36-1.fc16                                          
  wine-pulseaudio.x86_64 0:1.3.36-1.fc16                                        
  wine-small-fonts.noarch 0:1.3.36-1.fc16                                       
  wine-symbol-fonts.noarch 0:1.3.36-1.fc16                                      
  wine-system-fonts.noarch 0:1.3.36-1.fc16                                      
  wine-systemd.noarch 0:1.3.36-1.fc16                                           
  wine-tahoma-fonts.noarch 0:1.3.36-1.fc16                                      
  wine-twain.i686 0:1.3.36-1.fc16                                               
  wine-twain.x86_64 0:1.3.36-1.fc16                                             
  wine-wow.x86_64 0:1.3.36-1.fc16                                               
  xorg-x11-drv-wacom.x86_64 0:0.12.0-1.fc16                                     

After this update was installed, Eclipse couldn't find CDT after start. All the plugin perspectives are missing. The same applies to PyDev, Vrapper and several other plugins, I suspect it's a bug in eclipse-platform.x86_64 1:3.7.1-7.fc16.

Version-Release number of selected component (if applicable):
eclipse-platform.x86_64 1:3.7.1-7.fc16

How reproducible:
Just yum update and starting Eclipse should reproduce this if you had used eclipse previously (I have successfully reproduced it on 2 workstations with Fedora 16).

Steps to Reproduce:
1. yum install eclipse-cdt (with old eclipse-platform) 
2. start eclipse, observe that plugins work
3. yum update
4. start eclipse again, plugins are not found

Actual results:
Only inbuilt perspectives are available. No plugins are started (it seems).

Expected results:
CDT is found, C/C++ perspectives are available

Additional info:
After some digging around I found out that removing ~/.eclipse forces the app to do plugin search again and plugins are found as expected. If this really is necessary, user should be notified. Installing eclipse-platform fresh works as expected but the update path is broken.
Comment 1 Martin Preisler 2012-01-12 08:37:12 EST

*** This bug has been marked as a duplicate of bug 760454 ***

Note You need to log in before you can comment on or make changes to this bug.