Bug 773652 - [ath9k] randomly disconnects wireless[AR9285] --- lenovo g475
Summary: [ath9k] randomly disconnects wireless[AR9285] --- lenovo g475
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-12 14:00 UTC by moonshine
Modified: 2012-03-13 13:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 755370
Environment:
os:f16-64-live hardware: lenovo g475 + AR9285 tools: yum install -y gcc kernel-devel compat-wireless-2012-02-04 kernel-3.2.5-3.fc16.x86_64
Last Closed: 2012-03-13 13:02:42 UTC


Attachments (Terms of Use)
tail 500 /var/log/msg (58.45 KB, application/octet-stream)
2012-01-12 14:00 UTC, moonshine
no flags Details
/var/log/messages with kernel-3-2 (71.43 KB, application/x-gzip)
2012-01-30 00:45 UTC, moonshine
no flags Details
/var/log/msg with kernel3.2.3-2+compat-wireless-20120204 (24.08 KB, application/x-bzip)
2012-02-05 15:37 UTC, moonshine
no flags Details

Description moonshine 2012-01-12 14:00:19 UTC
Created attachment 552407 [details]
tail 500 /var/log/msg

Description of problem:
A wireless connection in an environment that used to be fine for use (also with
distance, walls between access point etc) gets now randomly and aggressively
disconnected by NetworkManager since a recent system update.

Version-Release number of selected component (if applicable):
f16-amd64 and all package is the lastest recent..

How reproducible:
go online, and it randomly disconnects

Additional info:
bash>lspci -v
...
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: Lenovo Device 30a1
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at 90000000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
	Capabilities: [170] Power Budgeting <?>
	Kernel driver in use: ath9k
	Kernel modules: ath9k

Comment 1 moonshine 2012-01-12 14:10:34 UTC
[root@localhost return]# lsmod
Module                  Size  Used by
tcp_lp                  2383  0 
ppdev                   8131  0 
parport_pc             21058  0 
lp                     10418  0 
parport                35827  3 ppdev,parport_pc,lp
fuse                   69330  3 
8021q                  19145  0 
garp                    6733  1 8021q
stp                     2007  1 garp
llc                     5106  2 garp,stp
fcoe                   21071  0 
libfcoe                35751  1 fcoe
libfc                 102240  2 fcoe,libfcoe
scsi_transport_fc      49307  2 fcoe,libfc
scsi_tgt               11403  1 scsi_transport_fc
ip6t_REJECT             4451  2 
nf_conntrack_ipv6       8338  1 
nf_defrag_ipv6          9740  1 nf_conntrack_ipv6
ip6table_filter         1735  1 
ip6_tables             19304  1 ip6table_filter
nf_conntrack_ipv4       9030  1 
nf_defrag_ipv4          1561  1 nf_conntrack_ipv4
xt_state                1370  2 
nf_conntrack           76503  3 nf_conntrack_ipv6,nf_conntrack_ipv4,xt_state
snd_hda_codec_conexant    60600  1 
snd_hda_intel          26342  4 
snd_hda_codec          97519  2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep               6891  1 snd_hda_codec
snd_seq                58599  0 
snd_seq_device          6425  1 snd_seq
snd_pcm                89984  3 snd_hda_intel,snd_hda_codec
arc4                    1481  2 
ath9k                  87883  0 
mac80211              244208  1 ath9k
uvcvideo               66310  0 
ath9k_common            2904  1 ath9k
ath9k_hw              369409  2 ath9k,ath9k_common
videodev               92903  1 uvcvideo
snd_timer              22199  2 snd_seq,snd_pcm
snd                    71085  15 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
media                  12416  2 uvcvideo,videodev
sp5100_tco              5465  0 
ath                    16506  3 ath9k,ath9k_common,ath9k_hw
i2c_piix4              10982  0 
soundcore               7124  1 snd
snd_page_alloc          8061  2 snd_hda_intel,snd_pcm
v4l2_compat_ioctl32     9334  1 videodev
k10temp                 3391  0 
joydev                 10372  0 
cfg80211              181887  3 ath9k,mac80211,ath
atl1c                  35691  0 
uinput                  8254  0 
microcode              19616  0 
ideapad_laptop          6616  0 
sparse_keymap           3854  1 ideapad_laptop
rfkill                 17938  3 cfg80211,ideapad_laptop
video                  12388  0 
radeon                996084  3 
ttm                    61533  1 radeon
drm_kms_helper         30277  1 radeon
drm                   213647  5 radeon,ttm,drm_kms_helper
i2c_algo_bit            5572  1 radeon
i2c_core               28203  6 videodev,i2c_piix4,radeon,drm_kms_helper,drm,i2c_algo_bit
[root@localhost return]# 
[root@localhost return]# uname -a
Linux localhost.localdomain 3.1.8-2.fc16.x86_64 #1 SMP Sat Jan 7 13:35:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@localhost return]#

Comment 2 moonshine 2012-01-30 00:45:14 UTC
Created attachment 558239 [details]
/var/log/messages  with kernel-3-2

[root@manhh3 ~]# uname -a
Linux manhh3 3.2.2-1.fc16.x86_64 #1 SMP Thu Jan 26 03:21:58 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@manhh3 ~]# cat /var/log/messages
...

Comment 3 Mohammed Shafi 2012-02-01 11:55:41 UTC
http://linuxwireless.org/en/users/Download#Where_to_download_bleeding_edge
with the above package please enable MAC80211_DEBUG and ATH_DEBUG ATH9K_DEBUG

CONFIG_ATH_DEBUG=y
CONFIG_ATH9K_DEBUGFS=y

CONFIG_MAC80211_DEBUGFS=y
# CONFIG_MAC80211_NOINLINE=y
CONFIG_MAC80211_VERBOSE_DEBUG=y
CONFIG_MAC80211_HT_DEBUG=y
CONFIG_MAC80211_TKIP_DEBUG=y
CONFIG_MAC80211_IBSS_DEBUG=y
CONFIG_MAC80211_VERBOSE_PS_DEBUG=y
CONFIG_MAC80211_VERBOSE_MPL_DEBUG=y
CONFIG_MAC80211_VERBOSE_MHWMP_DEBUG=y
#CONFIG_MAC80211_VERBOSE_TDLS_DEBUG
# CONFIG_MAC80211_DEBUG_COUNTERS=y



in config.mk of compat wireless and please post the log.
is the environments is noisy

Comment 4 moonshine 2012-02-03 13:37:48 UTC
thank you, Mohammed Shafi

i do following things:
1, yum install gcc
2, download the package and extract
3, modify config.mk as your show and make


but it seems something error:
sorry, i have little exprience in linux, need more help...

=====
[root@manhh3 compat-wireless-2012-02-02]# make
/home/shell/compat-wireless-2012-02-02/config.mk:254: "WARNING: CONFIG_CFG80211_WEXT will be deactivated or not working because kernel was compiled with CONFIG_WIRELESS_EXT=n. Tools using wext interface like iwconfig will not work. To activate it build your kernel e.g. with CONFIG_LIBIPW=m."
make -C /lib/modules/3.2.2-1.fc16.x86_64/build M=/home/shell/compat-wireless-2012-02-02 modules
make: *** /lib/modules/3.2.2-1.fc16.x86_64/build: No such file or directory.  Stop.
make: *** [modules] Error 2
[root@manhh3 compat-wireless-2012-02-02]#

Comment 5 John W. Linville 2012-02-03 18:24:28 UTC
moonshine, you need to do this first (as root):

yum install kernel-devel

Then you should be able to build compat-wireless locally.  Does that help?

Comment 6 moonshine 2012-02-03 23:50:57 UTC
[shell@manhh3 ~]$ cd compat-wireless-2012-02-02/
[shell@manhh3 compat-wireless-2012-02-02]$ ./scripts/driver-select ath9k
Processing new driver-select request...
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backup exists: Makefile.bk
Backup exists: drivers/net/wireless/Makefile.bk
Backup exists: drivers/net/wireless/ath/Makefile.bk
Backup exists: net/wireless/Makefile.bk
Backup exists: drivers/ssb/Makefile.bk
Backup exists: drivers/bcma/Makefile.bk
Backup exists: drivers/misc/eeprom/Makefile.bk
Backup exists: Makefile.bk
[shell@manhh3 compat-wireless-2012-02-02]$ make
/home/shell/compat-wireless-2012-02-02/config.mk:254: "WARNING: CONFIG_CFG80211_WEXT will be deactivated or not working because kernel was compiled with CONFIG_WIRELESS_EXT=n. Tools using wext interface like iwconfig will not work. To activate it build your kernel e.g. with CONFIG_LIBIPW=m."
make -C /lib/modules/3.2.2-1.fc16.x86_64/build M=/home/shell/compat-wireless-2012-02-02 modules
make: *** /lib/modules/3.2.2-1.fc16.x86_64/build: No such file or directory.  Stop.
make: *** [modules] Error 2
[shell@manhh3 compat-wireless-2012-02-02]$ rpm -q gcc
gcc-4.6.2-1.fc16.x86_64
[shell@manhh3 compat-wireless-2012-02-02]$ rpm -q kernel
kernel-3.1.0-7.fc16.x86_64
kernel-3.2.2-1.fc16.x86_64
[shell@manhh3 compat-wireless-2012-02-02]$ rpm -q kernel-devel
kernel-devel-3.2.2-1.fc16.x86_64
[shell@manhh3 compat-wireless-2012-02-02]$

Comment 7 moonshine 2012-02-05 15:37:19 UTC
Created attachment 559472 [details]
/var/log/msg with kernel3.2.3-2+compat-wireless-20120204

ok, 
i could catch new /var/log/msg now, with the last kernel and compat-wireless

thank you for reviewing to the attachment.

==
[root@manhh3 ~]# ls /home/shell/compat-wireless-2012-02-04/
code-metrics.txt          drivers                  modules.order
compat                    enable-older-kernels     Module.symvers
compat_base_tree          include                  net
compat_base_tree_version  linux-next-cherry-picks  patches
compat_version            linux-next-pending       pending-stable
config.mk                 Makefile                 README
COPYRIGHT                 Makefile.bk              scripts
crap                      master-tag               udev
defconfigs                modules
[root@manhh3 ~]# uname -a
Linux manhh3 3.2.3-2.fc16.x86_64 #1 SMP Fri Feb 3 20:08:08 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@manhh3 ~]#

Comment 8 moonshine 2012-02-06 15:07:37 UTC
oh~~
sorry for poor English and happy Lantern Festival Day.

Comment 9 John W. Linville 2012-02-06 15:28:35 UTC
Not sure what is happening in comment 6...do you have a directory for 
/lib/modules/3.2.2-1.fc16.x86_64/build on your box?  Is there anything in it? 
It should be provided by the kernel-devel-3.2.2-1.fc16.x86_64 package.

Perhaps you should remove the compat-wireless-2012-02-02 directory and
re-extract a clean copy, then start over?

Comment 10 moonshine 2012-02-06 17:43:05 UTC
(In reply to comment #9)
> Not sure what is happening in comment 6...do you have a directory for 
> /lib/modules/3.2.2-1.fc16.x86_64/build on your box?  Is there anything in it? 
> It should be provided by the kernel-devel-3.2.2-1.fc16.x86_64 package.
> 
> Perhaps you should remove the compat-wireless-2012-02-02 directory and
> re-extract a clean copy, then start over?

hello, after kernel/kernel-devel update to version 3.2.3-2, it does ok.


pls see also comment #7 and i had post the last-est log /var/log/msg.

Comment 11 moonshine 2012-02-06 17:44:34 UTC
[root@manhh3 ~]# ls /home/shell/compat-wireless-2012-02-04/
code-metrics.txt          drivers                  modules.order
compat                    enable-older-kernels     Module.symvers
compat_base_tree          include                  net
compat_base_tree_version  linux-next-cherry-picks  patches
compat_version            linux-next-pending       pending-stable
config.mk                 Makefile                 README
COPYRIGHT                 Makefile.bk              scripts
crap                      master-tag               udev
defconfigs                modules
[root@manhh3 ~]# uname -a
Linux manhh3 3.2.3-2.fc16.x86_64 #1 SMP Fri Feb 3 20:08:08 UTC 2012 x86_64
x86_64 x86_64 GNU/Linux
[root@manhh3 ~]#

Comment 12 moonshine 2012-02-13 17:35:15 UTC
see also
https://bugzilla.redhat.com/show_bug.cgi?id=755370

thanks.

Comment 14 moonshine 2012-03-13 12:49:08 UTC
ok, this bug can be close now.

the latest kernel has fixed this bug or enhance the stability for ar9285. 

thank all our great engineers,


Note You need to log in before you can comment on or make changes to this bug.