Bug 773669 - AS / JMX plugin should warn users or display an error when it cannot connect to the JMX server
AS / JMX plugin should warn users or display an error when it cannot connect ...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Documentation (Show other bugs)
4.2
Unspecified Unspecified
medium Severity high (vote)
: ---
: JON 3.1.0
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On: 773661 790048
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-12 09:38 EST by Deon Ballard
Modified: 2012-08-22 20:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 773661
Environment:
Last Closed: 2012-08-22 20:07:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
secure JVM discovery (22.47 KB, application/vnd.oasis.opendocument.text)
2012-05-29 12:35 EDT, Deon Ballard
no flags Details

  None (edit)
Description Deon Ballard 2012-01-12 09:38:29 EST
+++ This bug was initially created as a clone of Bug #773661 +++

By default, the JMX console in EAP is secured. Due to this, the AS 5 plugin is not able to connect to the JMX server to retrieve the information it needs. However, it fails silently reporting that the otherwise smoothly running instance is unavailable instead of showing a plugin error.
The plugin should display an error to the user when it cannot connect to the JMX server instead of silently failing.
Comment 3 Deon Ballard 2012-04-03 11:23:33 EDT
Targeting 3.1.
Comment 4 Deon Ballard 2012-05-23 17:54:07 EDT
To note, I think this is the same issue as bug 811998.
Comment 5 Deon Ballard 2012-05-29 12:33:50 EDT
Assigning to Heikp for review.
Comment 6 Deon Ballard 2012-05-29 12:35:37 EDT
Created attachment 587456 [details]
secure JVM discovery

Howdy, Heiko.

When you have the time, just review the doc, mark any changes (track changes should be on), and re-attach the edited file. If I am missing anything, feel free to stick in a comment and let me know what I should add.

Thanks!
Deon

P.S. I haven't spell-checked yet.
Comment 7 Deon Ballard 2012-08-22 20:07:14 EDT
Since this will be QA'ed in bug 811998, and the docs are already live, I'm closing this review bug.

Note You need to log in before you can comment on or make changes to this bug.