Bug 77374 - AIC-7xxx Driver Reports "Corrupted Serial EEPROM"
AIC-7xxx Driver Reports "Corrupted Serial EEPROM"
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-05 18:29 EST by Duncan Sterling
Modified: 2015-01-04 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 18:11:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Duncan Sterling 2002-11-05 18:29:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313

Description of problem:
On a dual PIII, with an Adaptec 29160, kernel 2.4.18-10smp, Adaptec AIC7xxx
driver version: 6.2.6, I'm seeing very poor SCSI performance. 

"cat /proc/scsi/aic7xxx/0" produces (along with other more normal info)
"Corrupted Serial EEPROM". 

I assumed that this indicated the card was bad, but replacing it with a brand
new one resulted in the same error message and the same poor performance. The
same adapter when placed on another identical box (with earlier versions of the
AIC driver) worked as expected, and produced no error message.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot machine normally
2.
3.
	

Actual Results:  The error message "Corrupted Serial EEPROM" results when
issuing the command "cat /proc/scsi/aic7xxx/0", accompanied by poor SCSI
performance.

Expected Results:  No error message, and normal SCSI performance

Additional info:

The machine is a dual PIII-1.26, Supermicro MB, 512 M RAM, Adaptec 29160 SCSI
controller, multiple Seagate Cheetah 10k LVD drives. 

On identical hardware running RH 6.2, RH 7.1 and RH 7.2 (with identically
configured user software) I'm not seeing the problem; these machines, however,
are running version 5.2.4/5.2.0 of the Adaptec driver.

A similar single CPU machine running RH 7.3 and version 6.2.5 of the adaptec
driver doesn't exhibit the problem.

The speed loss (nearly 50% compared to nearly identical systems) is making the
machine practically unusable for it's intended application.

TIA for any and all advice/suggestions/potential fixes.
Comment 1 Duncan Sterling 2002-11-08 18:19:44 EST
One additional datapoint: right before the SCSI card is ID'd during bootup,
the following error message appears:

SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2

Note You need to log in before you can comment on or make changes to this bug.