Bug 773773 - SELinux is preventing /usr/bin/ruby from using the 'setuid' capabilities.
Summary: SELinux is preventing /usr/bin/ruby from using the 'setuid' capabilities.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ee6c2d2f60d66ec815369a11575...
: 773774 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-12 21:20 UTC by geminic86
Modified: 2012-01-31 22:02 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.10.0-74.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-31 22:02:59 UTC


Attachments (Terms of Use)

Description geminic86 2012-01-12 21:20:22 UTC
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-7.fc16.i686
reason:         SELinux is preventing /usr/bin/ruby from using the 'setuid' capabilities.
time:           Thu 12 Jan 2012 04:41:34 PM EST

description:
:SELinux is preventing /usr/bin/ruby from using the 'setuid' capabilities.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that ruby should have the setuid capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep deltacloudd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:deltacloudd_t:s0
:Target Context                system_u:system_r:deltacloudd_t:s0
:Target Objects                 [ capability ]
:Source                        deltacloudd
:Source Path                   /usr/bin/ruby
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ruby-1.8.7.357-1.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-71.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.1.0-7.fc16.i686 #1 SMP Tue Nov 1
:                              21:00:16 UTC 2011 i686 i686
:Alert Count                   1
:First Seen                    Thu 12 Jan 2012 04:38:21 PM EST
:Last Seen                     Thu 12 Jan 2012 04:38:21 PM EST
:Local ID                      b583d1a3-c17f-4322-b906-f51ba221ec2b
:
:Raw Audit Messages
:type=AVC msg=audit(1326404301.521:566): avc:  denied  { setuid } for  pid=2738 comm="deltacloudd" capability=7  scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:system_r:deltacloudd_t:s0 tclass=capability
:
:
:type=SYSCALL msg=audit(1326404301.521:566): arch=i386 syscall=setresuid32 success=yes exit=0 a0=63 a1=63 a2=63 a3=d0 items=0 ppid=2737 pid=2738 auid=4294967295 uid=99 gid=99 euid=99 suid=99 fsuid=99 egid=99 sgid=99 fsgid=99 tty=(none) ses=4294967295 comm=deltacloudd exe=/usr/bin/ruby subj=system_u:system_r:deltacloudd_t:s0 key=(null)
:
:Hash: deltacloudd,deltacloudd_t,deltacloudd_t,capability,setuid
:
:audit2allow
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t self:capability setuid;
:
:audit2allow -R
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t self:capability setuid;
:

Comment 1 Miroslav Grepl 2012-01-16 08:39:21 UTC
*** Bug 773774 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2012-01-16 08:41:47 UTC
I will need to allow it. But could you try to execute

$ auditctl -w /etc/shadow -p w

Try to recreate AVC. Then execute

$ ausearch -m avc -ts recent



Thank you.

Comment 3 Fedora Update System 2012-01-26 18:16:27 UTC
selinux-policy-3.10.0-74.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-74.fc16

Comment 4 Fedora Update System 2012-01-28 03:29:31 UTC
Package selinux-policy-3.10.0-74.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-74.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0983/selinux-policy-3.10.0-74.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-01-31 22:02:59 UTC
selinux-policy-3.10.0-74.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.