Bug 77389 - mouseconfig doesn't update /etc/X11/XF86Config
mouseconfig doesn't update /etc/X11/XF86Config
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-06 02:46 EST by Justin Georgeson
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 11:17:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Georgeson 2002-11-06 02:46:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
I am running mharris's CVS RPMs of XFree86 4.2.99.2 due to the graphics chipset
in my laptop (Intel 830, Dell Latitude C400). After upgrading to the CVS
packages, mouseconfig no longer updates /etc/X11/XF86Config. I thought maybe
mouseconfig looks for /etc/X11/XF86Config-4 instead, so I made a symlink to
XF86Config, but that didn't help. I have version 4.2.99.2-0.20021105.0 of X, and
4.26-1 of mouseconfig.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run mouseconfig
2. Select mouse type other than current setting
3. Select Ok, specifying to make changes to X config
	

Actual Results:  /etc/X11/XF86Config is not changed to reflect new settings

Expected Results:  /etc/X11/XF86Config should be updated with the new mouse
settings.

Additional info:
Comment 1 Justin Georgeson 2002-11-17 23:58:04 EST
This bug is 11 days old and is still in the NEW state. Is anyone going to do
anything with it?
Comment 2 Brent Fox 2002-11-18 10:57:34 EST
We plan on deprecating mouseconfig in the next release.  Can you try
redhat-config-mouse-1.0.2-4.noarch.rpm out of Rawhide and see if that fixes the
problem?

There is now a text interface to redhat-config-mouse.
Comment 3 Justin Georgeson 2002-11-21 01:48:59 EST
Sorry for the delay in my reponse, my hosting company seems to be holiding me
mail for days at a time. Back on topic. The package you suggest does update the
/etc/X11/XF86Config file, but not correctly. I selected MS Intellimouse (USB)
and the ZAxisMapping was not present, so the scroll wheel was disabled. Further,
and perhaps I should have specified, but I need something that works from kudzu.
I have a laptop, and don't always boot with the external mouse plugged in. The
prior version of redhat-config-mouse in graphical mode configured
/etc/X11/XF86Config the same as the new one in text mode (no ZAxisMapping). But
it failed to inform me I needed to restart X, and logging out and back in
(runlevel 5, so gdm is running) isn't enough. Also, running mouseconfig after
having run this new redhat-config-mouse yields an error about being unable to
load /etc/sysconfig/mouse. So this new redhat-config-mouse package gets closer
than mouseconfig, but doesn't fully configure the mouse.
Comment 4 Brent Fox 2002-12-12 11:58:12 EST
Oh, I see what you're saying.  I will work on this today.
Comment 5 Brent Fox 2002-12-12 14:05:08 EST
I have made a change to redhat-config-mouse that will make sure that the
ZAxisMapping is written to the XF86Config file, which should fix the problem.

The reason that mouseconfig no longer works is because of a change I made to the
way redhat-config-mouse writes out /etc/sysconfig/mouse so that PS/2 and USB
mice can work at the same time in console mode.  This is useful for laptops
especially.  mouseconfig doesn't know how to handle the "OPTIONS='-t imps2 -m
/dev/input/mice -M" line.  This is ok since we are removing mouseconfig for the
next release.  Instead, redhat-config-mouse now can run in text mode.  The
'mouseconfig' command will run redhat-config-mouse in text mode in the next release.

redhat-config-mouse-1.0.2-8 should fix the problem and should appear in Rawhide
in the next day or so.  QA, please verify that this has been fixed.
Comment 6 Justin Georgeson 2002-12-13 19:33:18 EST
I just installed redhat-config-mouse-1.0.2-8 on my laptop. It's looking pretty
sharp. This release does correctly detect and configure my USB mouse during
boot. There are a few problems though:

1) After detecting and configuring my USB mouse, only the USB mouse works in
console mode. The USB mouse is fully configured though (thumb button and wheel
both worh)).

2) When booting without the USB mouse connected and the USB mouse was configured
at shutdown, the missing USB mouse is removed and a generic 2 button USB mouse
is configured. 

Here's my /etc/sysconfig/mouse after this case

FULLNAME="Generic - 2 Button Mouse (USB)"
MOUSETYPE="imps2"
XEMU3="yes"
XMOUSETYPE="genericusb"
DEVICE=/dev/input/mice
OPTIONS="-t imps2 -m /dev/input/mice -M"

My /etc/X11/XF86Config file still has the prior USB config (including
ZAxisMapping). I can run redhat-config-mouse to manually specify the PS/2 mouse.
Afterwards I do this, both mice work in console mode, and only the PS/2 mouse
works in X (which is the expected behavior).

I wasn't aware of the support for both devices in console mode, I think that is
*really* slick.
Comment 7 Brent Fox 2003-02-18 17:04:50 EST
I just built redhat-config-mouse-1.0.5-1 that should appear in Rawhide tomorrow.  

I had to remove the "OPTIONS" line from /etc/sysconfig/mouse because it causes
gpm to run in repeater mode, which can cause the mouse to go bonkers in X if X
and gpm are running at the same time.  See bug #76713 for more information.

Now, to get both mice to work in XFree86, you need to pick the PS/2 mouse from
the list.  The USB mouse config is always configured as the secondary mouse in
XF86Config, so you need to pick the PS/2 mouse to get both to work.  If you pick
the USB mouse, then only the USB mouse will work.  I could probably improve this
behavior a bit, but it's too late for this release.
Comment 8 Justin Georgeson 2003-02-19 10:50:47 EST
I've recently done a clean install of Phoebe2 (8.0.93) and the
redhat-config-mouse in that release has been working quite well for me thus far.
For my purposes this bug may be closed/resolved. Thanks.
Comment 9 Brent Fox 2003-02-19 11:17:22 EST
Ok, great.  Thanks for all your help on this report.  Closing as "rawhide"

Note You need to log in before you can comment on or make changes to this bug.