Bug 77392 - Installation of Linux Redhat 8.0
Installation of Linux Redhat 8.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-06 04:49 EST by Nicolas CROISET
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 14:41:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas CROISET 2002-11-06 04:49:56 EST
Description of Problem:
When you install redhat 8.0 or redhat 7.2 with two hard disk one in hda and the
other one in hdc. These two harddisk are identical (IBM 41 GB IC35L040AVVA07-0).
The motherboard is a rocky-3702EV-V4.

hda is discover as : 2005 cyl / 255 heads / 63 sectors
hdc is discover as : 79780 cyl / 16 heads / 63 sectors

This is a little problem when you make RAID 1 in soft.
If you modify these values by hand with fdisk to makes it identical via redhat
interface, these values are not saved.
If you modify these values by hand via a tty console these values are correctly
saved.

When you return via the graphic interface, linux redhat installer find that hdc
is not good when you make back and next...

The good solution is to find the same number od fectors/head and cylinders in
hda and hdc when you have identical disks.

when you put these harddisks in hda and hdb, the values are identical.

I do the same test on another machine which have the same motherboard and the
same hardisks, the problem is the same so it's not a hardware problem.

In the bios in autodetect mode, the harddisk are configured identical.
Comment 1 Michael Fulbright 2002-11-06 11:49:35 EST
Are the primary and secondary IDE controllers on your system using the same IDE
chipset?

This appears to be a kernel geometry detection issue.
Comment 2 Nicolas CROISET 2002-11-06 12:15:11 EST
The website of this motherboard is at :
http://www.ieiworld.com/products/sbc/rocky-3702ev.pdf

In the file /etc/sysconfig/hwconf, I have these informations :

class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corporation|82371AB PIIX4 ISA"
vendorId: 8086
deviceId: 7110
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corporation|82371AB PIIX4 IDE"
vendorId: 8086
deviceId: 7111
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: OTHER
bus: PCI
detached: 0
driver: sonypi
desc: "Intel Corporation|82371AB PIIX4 ACPI"
vendorId: 8086
deviceId: 7113
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "DEC|DECchip 21150"
vendorId: 1011
deviceId: 0022
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-
class: NETWORK
bus: PCI
detached: 0
device: eth
driver: 8139too
desc: "Realtek|RTL-8139"
vendorId: 10ec
deviceId: 8139
subVendorId: 10ec
subDeviceId: 8139
pciType: 1
-
class: HD
bus: IDE
detached: 0
device: hda
driver: ignore
desc: "IC35L040AVVN07-0"
physical: 19710/16/255
logical: 5005/255/63
-
class: HD
bus: IDE
detached: 0
device: hdc
driver: ignore
desc: "IC35L040AVVN07-0"
physical: 19710/16/255
logical: 5005/255/63
-

We had forced the logical via the console to have the same on the two harddisks.

I hope this will help you a little.
Comment 3 Alan Cox 2003-06-05 08:38:06 EDT
The kernel pulls hda/b info from the CMOS data but cannot do so for hdc/hdd.
This can lead to slightly different sizes being apparent for the two disks but
that isnt a problem, the raid layer will adjust a mirror appropriately to fit
the slightly smaller drive.

Using fdisk to set the geometry works. I wonder if the installer simply cached
the data.

Comment 4 Michael Fulbright 2003-06-12 15:40:44 EDT
If this is the case I would suspect parted.

Note You need to log in before you can comment on or make changes to this bug.