Bug 77411 - Cannot delete expired certificate
Cannot delete expired certificate
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mozilla-psm (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
https://twist.phys.ualberta.ca
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-06 12:57 EST by Konstantin Olchanski
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-11 13:12:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Olchanski 2002-11-06 12:57:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021025

Description of problem:
In mozilla-1.0.1-2.7.3, I cannot delete an expired ssl certificate. Selecting it
in the PSM and clicking delete->ok, produces no errors, but the certificate is
not deleted. Later versions of mozilla have other anomalies dealing with expired
certificates.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. go to edit->preferences->privacy->certificates
2. select the expired certificate
3. click on delete, then ok.
	

Actual Results:  nothing happens. the certificate is not deleted.

Expected Results:  the certificate is deleted or an error dialog.


Additional info:

A search of bugzilla.mozilla.org shows that certificate expiration was and is
problematic, for example, see http://bugzilla.mozilla.org/show_bug.cgi?id=171219.
K.Olchanski
Comment 1 Christopher Blizzard 2002-11-11 13:19:29 EST
Same as mozilla bug:

http://bugzilla.mozilla.org/show_bug.cgi?id=178684

If it gets fixed upstream I'll pull it in.

Note You need to log in before you can comment on or make changes to this bug.