Bug 77456 - Installer hangs after loading the LVM module
Installer hangs after loading the LVM module
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-07 06:54 EST by Carl Swart
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 02:29:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carl Swart 2002-11-07 06:54:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I am trying to get RedHat 8.0 installed on a SuperMicro 6010H 1U server. 
Everytime after loading the LVM module the machine hangs completely.

The output to the terminal is:
.... snip ....
<6>md: raid5 personality registered as nr 4
<6>Journalled Block Device driver loaded
<6>LVM version 1.0.3(19/02/2002) module loaded

The above is only valid for RedHat Version 8.0. I have successfully installed 
RedHat Linux Versions 6.2, 7.2 and 7.3 on the exact same machine. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from the CDROM or a boot disk.
2. Try to install RedHat 8.0 using any method.
	

Actual Results:  The system just hangs as described.

Expected Results:  I expect to be able to install RedHat 8.0 on the server with 
the same amount of ease, that I experienced when installing RedHat 6.2, 7.2 or 
7.3

Additional info:
I have the latest BIOS releases loaded for the motherboard. The system runs on 
an Adaptec 7899 SCSI chip. The hardware is not at fault, since all the other 
version of RedHat, and other distributions, install without a glitch.
Comment 1 Carl Swart 2002-11-07 09:22:46 EST
I have tried this update provided by katzj@rehat.com, but no luck, still 
exactly the same result.

*** From Bug ID # 74719 ***
Can you try with the update disk available at
http://people.redhat.com/~katzj/80update.img and see if it fixes the problem?
Comment 2 Michael Fulbright 2002-11-07 13:18:43 EST
Have you tested your media?
Comment 3 Carl Swart 2002-11-08 01:08:04 EST
I have burned 2 CD's and tested both CD's on the machine giving me hassles as 
well as another machine. On both machines, the tests were successful.
Comment 4 Jeremy Katz 2003-01-02 22:59:33 EST
Does it work if you boot with 'linux noapic'?  Also, what's the last thing on
tty1 and tty3?
Comment 5 Carl Swart 2003-01-03 01:19:54 EST
Thank yor for getting back to me on this issue now. Unfortunately the server 
that was giving me this problem is now in production for almsot 3 months, and 
it is functioning 100% runing RedHat 8.0. 

I never tried the 'linux noapic' boot command, or at least not that I can 
remember.

I solved the problem as follows:
1. I install the SCSI harddisk in another machine.
2. I did a base install of RedHat 8.0
3. I downloaded and compiled kernel 2.4.19
4. I removed the SCSI disk from the install machine and added it to the server.
5. I rebooted the server, and started to configure it.

After the above procedure I have not had one problem with the server. Please 
note that kernel 2.4.19, that was compiled by myself does have APIC support 
enabled, but no LVM support.

I will gladly provide you with a copy of my .config file for 2.4.19, if that 
will help you resolve the problem.

Thank again, and have a prosperous new year.
Comment 6 Jeremy Katz 2003-01-03 02:29:02 EST
Hmmm, without any further information, I'm going to have to guess it's something
hardware specific.  If you run into the problem again, feel free to reopen and
add any additional information you can.

Note You need to log in before you can comment on or make changes to this bug.