Bug 77489 - Please update to pcmcia-cs 3.2.3
Please update to pcmcia-cs 3.2.3
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-07 16:33 EST by Dr. Tilmann Bubeck
Modified: 2015-01-04 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:21:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for pcmcia-cs fixing the initialisation problem for pd6729 (1.27 KB, patch)
2002-11-10 14:46 EST, Dr. Tilmann Bubeck
no flags Details | Diff

  None (edit)
Description Dr. Tilmann Bubeck 2002-11-07 16:33:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.1) Gecko/20020827

Description of problem:
My hardware is only supported by pcmcia-cs version 3.2.3, because of a bug in
any version up to 3.2.2. Could you please update your very old version 3.1.31
dated from 2002-01-02?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert 3com 3c589
2. Recognize that the card is seen as memory (instead of NIC)
3. Update to pcmcia-cs 3.2.3
4. See its working now.
	

Actual Results:  Card is recognized as memory:

PCI: Assigned IRQ 9 for device 00:0d.0
  Cirrus PD6729 rev 00 PCI-to-PCMCIA at slot 00:0d, port 0x3e0
    host opts [0]: [ring] [1/3/2] [1/9/2]
    host opts [1]: [ring] [1/3/2] [1/9/2]
    ISA irqs (default) = 3,4,7,9,10,11,12 polling interval = 1000 ms
cs: memory probe 0x0d0000-0x0dffff: excluding 0xd0000-0xdffff
cs: memory probe 0x0c0000-0x0cffff: excluding 0xc0000-0xcffff
memory_cs: mem0: anonymous: unknown size


Expected Results:  Card should be recognized as a network pcmcia 3c589.

Additional info:

See bug database of pcmcia-cs package at sourceforge for a technical discussion
of the bug (in pcmcia-cs) itself.

Bugs item #594749, was opened at 2002-08-13 12:48
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=102405&aid=594749&group_id=2405
Comment 1 Arjan van de Ven 2002-11-07 16:37:42 EST
we don't ship any of the pcmcia-cs kernel bits but use the 2.4 kernel bits
instead, and unfortionatly the bug you reference has no real useful information ;(
Comment 2 Dr. Tilmann Bubeck 2002-11-10 14:40:12 EST
Taken from PCMCIA-HOWTO:

  In the standalone pcmcia-cs drivers, the i82365 module supports both
  ISA-to-PCMCIA, PCI-to-PCMCIA, and PCI-to-CardBus bridges.  The CardBus
  socket driver in the 2.4 tree is the yenta_socket driver.  It is
  selected by the CONFIG_CARDBUS option.  In your PCMCIA startup
  options, this driver should be specified in place of the i82365
  driver.  The kernel version of the i82365 driver, selected by
  CONFIG_I82365, only supports ISA-to-PCMCIA bridges.  PCI-to-PCMCIA
  bridges that are not CardBus capable, like the Cirrus PD6729, are not
  supported at all by the kernel PCMCIA drivers.

My card controller is a PD6729. This means, it is not supported by RHAT 8.0
because you are using the kernel drivers.

So I ask you to deliver the standalone pcmcia-cs drivers. However, because of a
bug in pcmcia-cs up to and including 3.2.2 you should use at least 3.2.3. The
bug in detail could be seen from the patch attached. The author writes in its
CHANGES: Fixed i82365 driver to do a better job of initializing PCI bridges on
2.4.* kernels.
Comment 3 Dr. Tilmann Bubeck 2002-11-10 14:46:02 EST
Created attachment 84445 [details]
patch for pcmcia-cs fixing the initialisation problem for pd6729
Comment 4 Arjan van de Ven 2002-11-10 14:50:15 EST
that howto is not quite correct.
Linux 2.4 does support PCI->PCMCIA bridges. However not all of them right now;
mostly because of lack of hardware availability. Looking at the datasheet
briefly, it appears to not be too hard to add pd6729 support into that driver
assuming you are willing to test.
Comment 5 Dr. Tilmann Bubeck 2002-11-11 02:04:45 EST
Yes! I would love to do anything to elminate the bug. I could test your driver 
and also do some minor modifications (if you tell me what). I program C since 
years, so trying out various #ifdef's is no problem. Feel free to tell me what 
to do!
Comment 6 Dr. Tilmann Bubeck 2002-11-11 02:07:07 EST
Just to make one last thing clear. The PD6729 _is_ supported by the standalone 
pcmcia-cs drivers. So it might help looking at "i82365.c" from pcmcia-cs, 
because this is working!
Comment 7 Dr. Tilmann Bubeck 2002-11-28 13:28:33 EST
Have you made any progress yet? Is there anything I can test or help? Please let
me know.

Note You need to log in before you can comment on or make changes to this bug.