Bug 77499 - printtool crashes on uniprint drivers
printtool crashes on uniprint drivers
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-07 18:39 EST by Lynn Kerby
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:04:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lynn Kerby 2002-11-07 18:39:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.2.14-5.0 i686)

Description of problem:
When configuring printers that use the uniprint (ghostscript) driver
settings, printtool crashes.  This is on an old (but mostly updated)
RedHat 6.2 installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install updated printtool rpm (printtool-3.44-2)
2. Install updated ghostscript rpm (ghostscript-6.51-16.1.6x.1)
3. configure an epson stylus color printer and hit OK
	

Actual Results:  No color depth/uniprint mode selection present when
configuring.  Clicking on OK results in a dialog box from Tcl/Tk.

Additional info:

The problem is due to the new location of printer 'upp' files in the
ghostscript_6.51 package.  Changing the path of upp files on line
1429 of /usr/bin/printtool from /usr/share/ghostscript/*/$fname to
/usr/share/ghostscript/*/lib/$fname seems to resolve the problem.
Comment 1 Tim Waugh 2002-12-23 07:04:51 EST
The suggested work-around sounds like the right fix.  Thanks.
Comment 2 Bill Nottingham 2006-08-07 15:44:52 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Bill Nottingham 2006-10-18 13:04:11 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.