Bug 77505 - display corruption on Chips & Technologies CT65554
display corruption on Chips & Technologies CT65554
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-07 20:42 EST by Rick Gaudette
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-22 03:51:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Gaudette 2002-11-07 20:42:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Just about any window operation leaves un-updated window regions on the display.
 The most obvious is using a scroll bar which will leave many repeated or grey
regions in the window.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use scroll bar in any window sliding causes more courrption than stepping
2.i.e. terminals (all), mozilla or the redhat system logs app are good examples 
3.	

Actual Results:  display becomes corrupted

Expected Results:  display should not become corrupted

Additional info:

This is on an old HP omnibook Pentium 166 w/ 32 MB of ram if that makes any
difference
Comment 1 Mike A. Harris 2002-11-08 08:13:16 EST
I'm working on trying to fix some bugs in the chips driver right now
due to the XFree86 driver having some breakage that has been reported.

Unfortunately I don't have any chips hardware, so I need someone who does
have it to do some tests for me so I can fix it.  I also need to see
a screenshot of this corruption if possible.  So first step, is to make
a screenshot and attach it to the bug report using the link below, as
well as your X config file and log file.  I also need the output of
"lspci -vvn" for debugging.

Next step, is to try different troubleshooting tests:

First test, in your XF86Config, put in the Device section:
     Option "noaccel"

If that makes the problem go away, then we know it is a 2D acceleration
bug (most likely).

Next test is to find out exactly what is broken.  To do that, I need you
to read the "man XF86Config" manual, and look for the various "XaaNo....."
options.  Remove the above "noaccel" option from the config file, and try
_one_ of the XaaNo options.  After adding one of them, start the X server
and test to see if the corruption is gone.  If the corruption persists,
quit X, comment out or remove the XaaNo option, and replace it with
another XaaNo option.  Continue through the list until you've tried
every option.  If any one option solves the problem, indicate what option
it is to me, and please attach a new X config file and log from the
server ran with this XaaNo option being used.

If noaccel worked, but no one single option solves the problem for you,
try using multiple XaaNo options, and try to narrow it down.  If you
can narrow it down to one or two options, then I can probably fix the
driver.

Thanks.

Comment 2 Mike A. Harris 2002-12-22 03:51:46 EST
Reported as working by a user in rawhide XFree86 as of December 17th,
so closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.