Bug 77509 - Wrong K2 and K3 entries in termcap
Wrong K2 and K3 entries in termcap
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: termcap (Show other bugs)
8.0
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-07 23:05 EST by Leonard den Ottolander
Modified: 2015-01-07 19:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-15 07:57:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff updates wrong ka3 and kb2 entries, removes redundant ka3 and kf0 entries (SRPM) (1.32 KB, patch)
2002-11-07 23:14 EST, Leonard den Ottolander
no flags Details | Diff
diff updates wrong ka3 and kb2 entries, removes redundant ka3 and kf0 entries (RPM) (1.49 KB, patch)
2002-11-07 23:15 EST, Leonard den Ottolander
no flags Details | Diff

  None (edit)
Description Leonard den Ottolander 2002-11-07 23:05:49 EST
Description of Problem:

 Errors in different terminfo & -cap files in ncurses-5.2.28.src.rpm and
termcap-11.0.1-13.rpm and -.src.rpm (also see bug #77506).

termcap-11.0.1-13.rpm /etc/termcap:

K2 and K3 values swapped in entries:
 xterm-xfree86|xterm-new|xterm terminal emulator (XFree86):\
 wy520|wyse520|wyse 520:\
 ncr260vt100an|NCR 2900_260 vt100 with ansi kybd:\
 ncr260vt200an|NCR 2900_260 vt200 with ansi kybd:\
 ncr260vt300an|NCR 2900_260 vt300 with ansi kybd:\
 z39-a|z39a|zenith39-a|zenith39-ansi|Zenith 39 in ANSI mode:\
 (K2=\EOy should be K2=\EOu and K3=\EOu should be K3=\EOy,
  see vt320|vt300|dec vt320 7 bit terminal:\, it uses
  :K1=\EOw:K2=\EOu:K3=\EOy:K4=\EOq:K5=\EOs:LE=\E[%dD:\)
 (replaced with correct values in provided diff)

redundant and wrong entry K3=\EOu in (already defined in ncr260vt[1-3]00an):
 ncr260vt100pp|NCR 2900_260 vt100 with PC+ kybd:\
 ncr260vt200pp|NCR 2900_260 vt200 with pc+ kybd:\
 ncr260vt300pp|NCR 2900_260 vt300 with pc+ kybd:\
 (entries deleted in provided diff)

redundant k0=\EOy in:
 ncr260vt200an|NCR 2900_260 vt200 with ansi kybd:\
 ncr260vt300an|NCR 2900_260 vt300 with ansi kybd:\
 (entries deleted in provided diff)

and (I almost forgot) wrong K2=\217y and K3=\217u in:
 xterm-8bit|xterm terminal emulator with 8-bit controls (X Window System):\
 (see bq300-8|Bull vt320 full 8 bits 80 columns:\ for correct values)
 (replaced correct values in diff)


termcap-11.0.1-13.src.rpm terminfo.src:
same wrong entries as in termcap-11.0.1-13.src.rpm /etc/termcap
using kb2 etc. instead of K2 etc.

Version-Release number of selected component (if applicable):
termcap-11.0.1-13.src.rpm and termcap-11.0.1-13.noarch.rpm

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Leonard den Ottolander 2002-11-07 23:14:58 EST
Created attachment 84148 [details]
diff updates wrong ka3 and kb2 entries, removes redundant ka3 and kf0 entries (SRPM)
Comment 2 Leonard den Ottolander 2002-11-07 23:15:46 EST
Created attachment 84149 [details]
diff updates wrong ka3 and kb2 entries, removes redundant ka3 and kf0 entries (RPM)
Comment 3 Leonard den Ottolander 2003-07-31 21:19:23 EDT
Bug #77506 was closed because this was actually fixed in ncurses. This bug can
thus be closed as well.

Note You need to log in before you can comment on or make changes to this bug.