Bug 77530 - Printtools won't work with HPOJ
Printtools won't work with HPOJ
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-08 11:50 EST by Clay Claiborne
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-21 05:49:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clay Claiborne 2002-11-08 11:50:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1)
Gecko/20020823 Netscape/7.0

Description of problem:
# RedHat 8.0's "printconf" utilities don't allow entering a device filename
longer than 20 characters, which makes it impossible to enter the necessary
"/var/run/ptal-printd/mlc_..."

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attempt to use  a Custom Device longer than 20 characters
2.
3.
	

Actual Results:  Won't work

Expected Results:  Should work

Additional info:

The main problem with setting up ptal-printd to work with RH8.0 appears 
to be that the RH printer configuration tools (printtools, printconf, 
redhat-config-printer-[gt](all the same as far as I can tell))ui don't 
allow enough space in the 'Custom Device' field to type in the full 
pathname of something like 
'/var/run/ptal-printd/mlc_usb_officejet_d_series.' I tried adding the 
necessary configuration info in /etc/printcap.local but this didn't work 
for me. What did work is this:

1) using printtools create an queue for the hpoj printer, in the Custom 
Device field type in something that will fit and can be easily searched 
for. I used '/officejet_d_series'. Save it. 2) Then export the printer 
configuration info to an xml file with the command:

>/usr/sbin/redhat-config-printer-tui --Xexport > settings.xml
>
3) Now load 'settings.xml' into your favorite text editor (vi) search 
for your 'Custom Device' string and replace it with the full device 
pathname. 4) Then import your modified setting.xml  with:

>/usr/sbin/redhat-config-printer-tui --Ximport < settings.xml


Now you can reload printtools and restart lpd and you should be able to
print a test page and declare victory. 
printttools doesn't seem to mind the very long 'Custom Device' field as
long as you don't try to edit it in printtools. 
Of course the best solution is for Red Hat modify it's printer utilities
to accommidate long 'Custom Device' strings.
Comment 1 Tim Waugh 2002-11-08 11:54:47 EST
Does redhat-config-printer-gui from rawhide (0.6.x) work correctly here?
Comment 2 Simon Cooper 2003-03-21 02:56:49 EST
The problem is that the device dialog box has been arbitarily restricted to
20 characters in size.

Attached are two very small patches which fix this problem for both the
"text" and graphics tools.  The fix increases the size of the input field to
80 characters.

Enjoy!

Simon.

--- usr/share/printconf/util/printconf_gui.py.~1~       2002-09-02
23:56:21.000000000 -0700
+++ usr/share/printconf/util/printconf_gui.py   2003-03-20 21:14:24.000000000 -0800
@@ -218,7 +218,7 @@
        p_label.set_alignment(1.0, 0.5)
        table.attach(p_label, 0, 1, 1, 2)

-       entry = gtk.Entry(20)
+       entry = gtk.Entry(80)
        entry.set_text(default)
        table.attach(entry, 1, 2, 1, 2)

--- usr/share/printconf/util/printconf_tui.py.~1~       2002-09-02
23:56:21.000000000 -0700
+++ usr/share/printconf/util/printconf_tui.py   2003-03-20 21:27:50.000000000 -0800
@@ -320,7 +320,7 @@

        name_grid.setField(Label(nqd.nametype.name_label_prompt), 0, 0, padding
= (0, 0, 0, 1), anchorLeft = 1)

-       name_entry = Entry(20)
+       name_entry = Entry(80)
        name_grid.setField(name_entry, 1, 0, anchorLeft = 1)
        name_entry.set(nqd.data.get("queue_name", ""))

Comment 3 Tim Waugh 2003-03-21 05:49:23 EST
Please try 0.6.49-1, which will appear in rawhide in due course.  In the mean
time, you can find it here:

ftp://people.redhat.com/twaugh/tmp/

Note You need to log in before you can comment on or make changes to this bug.