Bug 77567 - gcc 3.2 segfaults during compilation of mplayer
Summary: gcc 3.2 segfaults during compilation of mplayer
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 8.0
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-09 12:04 UTC by Victor Mierla
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 10:28:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Victor Mierla 2002-11-09 12:04:43 UTC
From Bugzilla Helper:
User-Agent: Opera/6.1 (Linux 2.4.19 i686; U)  [en]

Description of problem:
Download the  CVS snapshot of ffmpeg(www.ffmpeg.org) & compile it
Download the CVS snapshot of Mplayer(mplayer.sourceforge.net)
Compile mplayer-> error when linking with libavcodec(from ffmpeg)

rm /usr/local/lib/libavcodec.a

in mplayer tree
./configure (Do not make clean)
make

At interface.c (mplayer) :

gcc -c -O4 -march=athlon-tbird -mcpu=athlon-tbird -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fomit-frame-pointer -fexpensive-optimizations -fschedule-insns2 -Wall -malign-double -I. -I../loader -I./wm -I./skin -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include   -DDEBUG  -o interface.o interface.c
interface.c: In function `guiGetEvent':
interface.c:682: unrecognizable insn:
(insn 3688 3427 742 (set (reg/f:SI 671)
        (plus:SI (address:SI (const_int 2 [0x2]))
            (const_int -20 [0xffffffec]))) -1 (nil)
    (nil))
interface.c:682: Internal compiler error in extract_insn, at recog.c:2148
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [interface.o] Error 1
make[1]: Leaving directory `/pub/compile/MPlayer-20021108/Gui'
make: *** [Gui/libgui.a] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.
2.
3.
	

Expected Results:  To work??! :-)

Additional info:


i have 2.4.19 kernel,Nvidia ge force 2 Gts+accelerated drivers.
No oops or other kernel erros were present .

The distribution is not updated /mdofied in any way

Comment 1 Jakub Jelinek 2002-11-09 12:14:32 UTC
Please attach preprocessed source (interface.i; hint: add -save-temps
to the above command line).

Comment 2 Victor Mierla 2002-11-10 17:29:24 UTC
I'll send preprocessed source if will be able to reproduce the bug

Comment 3 Mathieu Chouquet-Stringer 2002-11-12 00:03:10 UTC
Same problem here. The strange thing is as kornos said, it is not easily
reproducible because when gcc segfaults, if you restart it, the compile process
continues without a glitch (as if gcc didn't really have a problem with that
specific source file)...
Same thing when I compile a kernel v2.5...

Comment 4 Michael Lee Yohe 2002-11-13 17:40:22 UTC
Motherboard problems can cause errors in GCC since GCC stresses out the
resources on your system.  Are you sure your system is up to spec (no freezes,
no overclocking, etc.)?  Is your memory name brand or house brand?

mplayer compile wfm on an Athlon box

$ rpm -q gcc
gcc-3.2-7


Comment 5 Jakub Jelinek 2002-11-14 09:59:46 UTC
If it is not reproduceable, then it means you either have faulty hardware,
or you run out of memory.

Comment 6 Victor Mierla 2002-11-15 19:47:37 UTC
Hi people

I'm very aware of the effects of faulty hardware on compilation with gcc. I was "blessed" with many of these on my k6-2/350 with via mb.

My system is ok.
It;s not overclocked or screwed in any way.
I have 512mb of Ram and 256 of swap.

On my k6-2/250 if i wanted to compile the kernel i would have to type make bzImage many times before it could finish it.
Many gcc segfaults were appearing.

This is not the case now.
gcc NEVER segfaulted while compiling the kernel.
I have this system for approx a year and this kind of gcc fault
apeeared 2 or 3 times.

Please do not CLOSE this bug.
I'll try to reproduce it , but for now i'm pretty busy at work.
Probably next week i'll take another lokok at it.


Thanks


Comment 7 Alan Cox 2002-12-16 02:04:31 UTC
You may also find you can only reproduce it if you have the nvidia binary only
3d stuff loaded. Thats worth checking just to be sure


Comment 8 Victor Mierla 2002-12-16 16:57:36 UTC
ooh...cool..Alan Cox replied.....
First of all , let me tell you theat i'm a big fan of your
"look'n'feel" (hair,style,etc).  :-)

You're totally right.
NVdriver module is a BIG pain in the ass.

It segfaults the X server , freezes the kernel,etc.
I think it's the only module that freezes the kernel with no oops
or other message.

Until now i've used the version 3123 ,which was quite acceptable.
however the last version 4194 slows X very much(especially gnome-terminal with a jpg as background).

However i couldn't imagine that it could affect gcc.
Now i understand why  the compilation in X have so many problems 
compared to the text terminal compilation.


Comment 9 Caeies 2003-01-11 14:35:23 UTC
I have the same pblm on 2 differents machine.
I try to compile the RH 8.0 kernel provided on a AMDk6-2/350 with 128 Mb RAM 
(128 SWAP) not overclocked
and under a ATHLON 1700 XP with 256 Mb of ram (and 256 SWAP)not overclocked  
(buy to compaq)
under the K6 gcc segfault a lot 'd of time and it's not reproductible !
same with the athlon.
I try to remove the -O2 option, and it made "less" segfaults...
The compaq have a nvidia drivers not loaded (but nvidia hw) because I prefered 
make the compilation myself.
I'm ready to help (ie make compilation with bug report) on both machine.
I'll try to do a silly thing : until make bzImage; do date; done
on my 350. the kernel was exploded after 5 minutes.
hope this help.

Comment 10 Caeies 2003-01-13 10:34:03 UTC
So I tried the following :
I downgrade to my old RH 7.2 with gcc-2.95-98
and  I dowload the gnu version of gcc-3.2.1 (the latest version on gnu.org)
I make it on my 350 (without any pblm) and try to make some compilation (bochs 
to be exact)
No Segfault where made.
I add that with the RH gcc under the 8.0 I have tried to make windowmaker, with 
a lot's of segfault with a nicely message saying that make a report on 
bugzilla .
Hope this help !
PS : I tried to compile gcc-3.2.1 under my athlon xp when my girls friends 
leave me it :)

Comment 11 Caeies 2003-01-16 10:08:17 UTC
As Alan Cox suggested in another bug,
I'have test the memory of my 2 computers with memtest86
without any errors.
So it does'nt seems to be a memory error ...
Hope this help.
(I Haven't enougth time to make more test under the Athlon XP)
Caeies

Comment 12 Richard Henderson 2004-10-03 10:28:49 UTC
Preprocessed file never got attached, and the entire comment log points
to buggy kernel module.


Note You need to log in before you can comment on or make changes to this bug.