Bug 77579 - Mozilla Mail Starts Blank after login
Mozilla Mail Starts Blank after login
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-09 12:22 EST by Stephen Lawrence Jr.
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:39:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen looks like this after re-loging in. Browser is fine, just mail loses everything. (22.26 KB, image/png)
2002-11-13 00:06 EST, Stephen Lawrence Jr.
no flags Details

  None (edit)
Description Stephen Lawrence Jr. 2002-11-09 12:22:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If I log out of KDE while mozilla and mozilla-mail are up and running, and I
select "save session", when I log back in, mozilla-mail starts up without any
mail servers.

Version-Release number of selected component (if applicable):

mozilla-1.0.1-26
mozilla-psm-1.0.1-26
mozilla-mail-1.0.1-26
mozilla-nss-1.0.1-26
mozilla-nspr-1.0.1-26

How reproducible:
Always

Steps to Reproduce:
1.Login, start mozilla, and mozilla-mail
2.logout, select "save session"
3.re-login
	

Actual Results:  Mozilla mail starts from last saved session, but has no mail
servers.

Expected Results:  Mozilla-mail should start up and load preferences and mail
server prefs.

Additional info:
This seemed to start after the last up2date on mozilla.
Comment 1 Stephen Lawrence Jr. 2002-11-09 12:25:33 EST
mozilla and mozilla-mail have to be closed, the re-opened to get mail functional
again.
Comment 2 Christopher Blizzard 2002-11-11 13:09:48 EST
Mozilla isn't session aware.

Are you losing settings?  Or do they show up on the next restart?

What happens if you don't leave it running while logging out of your session?
Comment 3 Stephen Lawrence Jr. 2002-11-11 17:32:02 EST
The mail server configuration is not lost permamently.

If I don't leave it running, or course, it load fine. This only happens when it
is left running during a logout with "Save Session" checked. This ALWAYS worked
before, where I have my konsole, gkrellm, mozilla, etc. loaded upon login.
Comment 4 Christopher Blizzard 2002-11-12 17:36:55 EST
Can you attach a screenshot of what's happening?  I need a little more context.
Comment 5 Stephen Lawrence Jr. 2002-11-13 00:06:16 EST
Created attachment 84764 [details]
Screen looks like this after re-loging in. Browser is fine, just mail loses everything.
Comment 6 Christopher Blizzard 2002-11-15 11:02:12 EST
Ahh.  I think I know what's happening here.  I saw this last night while I was
trying to work on another problem.

I'll bet that KDE is running the mozilla-bin file directly instead of running it
through the wrapper script.  This means that LD_LIBRARY_PATH isn't being set
properly and mozilla isn't able to load some of its libraries, causing that
really wierd problem.

(I'll bet it can't find libmsgbaseutil.so.)

You can do one of two things:

1. Turn of KDE's "I'm going to guess how to restart this program even though
it's not really session aware" functionality.

2. Add /usr/lib/mozilla-<version>/ to /etc/ld.so.conf
Comment 7 Bill Nottingham 2006-08-07 15:15:58 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 8 Bill Nottingham 2006-10-18 12:39:37 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.