Bug 77599 - ssh hangs if home directory is not writeable
ssh hangs if home directory is not writeable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-10 03:51 EST by santini
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 05:32:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description santini 2002-11-10 03:51:43 EST
Description of problem:
Trying to login to a user with a non writeable home directory result in ssh
hanging for indefinite time.

How reproducible:
Always

Steps to Reproduce:
1. Let foobar a user such that your key is in his authorized_keys
2. chmod a-w /home/foobar
3. ssh -v foobar@localhost
	
Actual Results:  ssh hanging after:

[...]
debug1: channel request 0: shell
debug1: fd 3 setting TCP_NODELAY
debug1: channel 0: open confirm rwindow 0 rmax 32768

Expected Results:  a normal login, since your key is listed in
~/foobar/.ssh/authorized_keys
Comment 1 Tomas Mraz 2005-02-04 05:32:21 EST
Cannot reproduce on the current Fedora Core.

Note You need to log in before you can comment on or make changes to this bug.