Bug 77600 - notificationarea draws the icon badly on menupanels. Its like the applet thinks it is larger than it is.
Summary: notificationarea draws the icon badly on menupanels. Its like the applet thin...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL: http://w1.370.telia.com/~u37006850/no...
Whiteboard:
Keywords: MoveUpstream
Depends On:
Blocks: GnomeUpstream
TreeView+ depends on / blocked
 
Reported: 2002-11-10 11:36 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2002-12-14 11:38:05 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-10 11:36:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
I deleted the panel that RedHat supplied me with in RH8.0 and created a
menupanel instead and added a notificationarea to that menupanel. Now the
notificationarea-applet draws the icon in the area wrong. Its like it thinks it
is larger than it is. The picture in the supplied URL shows the gnomeicuicon
beeing drawed at the top of the area so only the bottom of the icon is showed.
This happens all the time with the menupanel. Also it happens with the
authorizationicon. I cant test more application that uses the notificationarea
since i do not know about more programs that uses it.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Delete the supplied panel with RH 8.0
2. Add a menupanel and a notificationarea on that panel.
3. See the icons on the area get drawn badly.
	

Actual Results:  The icons do not draw correct. I only see the bottom half of
them :(

Expected Results:  The notificationarea should know about the menupanels size
and draw the icons correctly. 

Additional info:

Comment 1 Havoc Pennington 2002-12-13 21:56:54 UTC
I believe this is actually a bug in the icons themselves (e.g. gnomeicu),
in that they don't resize on receiving a smaller size allocation. But I could be
wrong.

Comment 2 Need Real Name 2002-12-14 11:38:05 UTC
Yes, that is probably true. It workes now, dont tell me how i did it, but i
belive it is becaus i restarted the computer.  So i'l delete this bug here. 
/kent.

Comment 3 Havoc Pennington 2002-12-16 18:21:25 UTC
Changing to MoveUpstream keyword instead of GnomeUpstream tracking bug.
sorry about the spam.


Note You need to log in before you can comment on or make changes to this bug.