Bug 77632 - (SOUND TRIDENT)ali_ac_97 complains "try clear busy flag!!" (accompanied by temporary skips of sound)
(SOUND TRIDENT)ali_ac_97 complains "try clear busy flag!!" (accompanied by te...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-11 02:56 EST by Cristian Draghici
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-19 05:05:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristian Draghici 2002-11-11 02:56:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Hi all,

The box is a hp omnibook xe4500 laptop (P4 1.6).
When running the stock (2.4.18-14) kernel the sound skips when playing from xmms
while the mozilla scrollbar is moved. It also happens when the terminal produces
the bell sound.
ali_ac97 logs the following in /var/log/messages:
----------------------
Nov 10 21:02:19 bluefish kernel: ali_ac97_set :try clear busy flag!!
Nov 10 21:48:23 bluefish last message repeated 10 times
Nov 10 21:49:13 bluefish last message repeated 24 times
-------------------------



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open xmms, play something
2. open mozilla, load a big html page
3. scroll the mozilla bar all the way down, then all the way up

	

Actual Results:  Sound playing skips accompanied by ali_ac97 message in syslog.

Expected Results:  Sound should play without skips.

Additional info:

Note: I cannot reproduce the problem with kernels:
2.4.18-3 (stock in 7.3)
2.4.19 (vanilla + acpi.sf.net patches)
2.5.40 (vanilla + acpi.sf.net patches)
Comment 1 Rogerio Pereira Junior 2002-11-18 09:29:51 EST
I have same problem with notebook Acer Travelmate 521TE running kernel 2.4.18-18.8.0
Comment 2 Joao Veiga 2002-11-22 14:22:26 EST
Same here with a Toshiba 1805-S254, stock 2.4.18-17.8.0.   
  
To be more specific, it not only scrolling. Dragging a window around real 
quick does it too. I though this was due to my processor speed (PIII 1GHz) 
(and using fb for X), but if you say other kernels don't do it, I'll try 
2.4.19. 
  
I do get a screeching sound with "screen activity" even when playing wav files 
from konqueror, but could not associate that with the "kernel: ali_ac97_set 
:try clear busy flag!!", or "kernel: ali_ac97_read :try clear busy flag" or 
the funny "kernel: r busy flag" on /var/log/messages. When the screeching 
happens, looking at tail -f /var/log/messages do not show new messages popping 
up. Try that. 
 
I can play wav files with /usr/bin/play on a Konsole window and drag the 
scrollbar like crazy on a Konqueror window with no screeching, clipping, nor 
messages. It's also less (but it is) affected by dragging a window around 
quickly. 
  
The messages actually seem to be logged when X is starting (I'm using KDE). 
There's so many occurences that "dmesg" is rendered unuseable (flooded with 
the messages).  
  
So there are maybe two problems; probably related to each other, but at least 
in my case, not happening simultaneously:  
1. Screeching/clipping when screen is quickly updated (fb related?) 
2. "try clear busy flag" messages flooding 
  
Strangely, among the hundreds of those busy flag messages, I found this one 
(1) in dmesg too:  
ac97_codec: AC97  codec, id: 0x0000:0x0000 (Unknown)  
 
Comment 3 Cristian Draghici 2003-03-01 04:52:27 EST
To all affected by this problem: you can use the alsa driver as a workaround.
You can get alsa rpms from freshrpms.net (alsa-kernel, alsa-lib, alsa-driver, etc).
Install the drivers, remove any module that is sound related (otherwise alsa
won't load the ali5451 driver because of conflict issues) and modprobe sound-card-0.
My /etc/modules.conf now lists:
------------
#alias sound-slot-0 trident
alias snd-card-0           snd-ali5451
alias sound-slot-0         snd-card-0
alias char-major-116       snd
alias char-major-14        soundcore
alias sound-service-0-3    snd-pcm-oss
alias sound-service-0-0    snd-mixer-oss
alias sound-service-0-1    snd-seq-oss
alias sound-service-0-12   snd-pcm-oss
alias sound-service-0-6    snd-pcm-oss
alias /dev/dsp             sound-service-0-3
------------
Comment 4 Muli Ben-Yehuda 2004-01-18 07:46:48 EST
I'd be very interested if you could reproduce this with the trident.c
driver in 2.4.latest, 2.6.latest or (best) 2.6.latest-mm. As far as I
can recall, this message was simply commented out, as (we thought at
the time) that it was harmless. If you can reproduce the sound skips
with a recent driver and verify that it doesn't happen with e.g. the
ALSA driver, I'll certainly take a look. 
Comment 5 Cristian Draghici 2004-01-18 08:04:12 EST
Hello

Now running 2.4.22-1.2149.nptl on Fedora Core 1 and the problem is gone.

I've also tried 2.6.1-1.138 (from the rpm packaged by ArjanV) but with
alsa (snd-trident), and that works too. Sorry I don't have non-alsa
drivers in the 2.6 kernel (the prepackaged one).
Comment 6 Muli Ben-Yehuda 2004-01-18 08:08:01 EST
Just to verify - with the FC1 kernel, you're using the OSS (trident.c)
driver? I'll grab the kernel SRPM and see which driver version is
included there, and whether it's patched. 

I'm sorry to hear that the OSS drivers have been removed from arjan's
2.6 kernel. I have at least one bug report where the alsa trident
driver didn't work, and the OSS driver did. 

Thanks for your feedback! 
Comment 7 Cristian Draghici 2004-01-18 08:16:38 EST
Yes, trident.c

From the trident.c comments part (I have the sources on my machine):
---------------
 *  History
 *  v0.14.10h
 *      Sept 10 2002 Pascal Schmidt <der.eremit@email.de>
 *      added support for ALi 5451 joystick port
 *  v0.14.10g
 *      Sept 05 2002 Alan Cox <alan@redhat.com>
 *      adapt to new pci joystick attachment interface
 *  v0.14.10f
 *      July 24 2002 Muli Ben-Yehuda <mulix@actcom.co.il>
 *      patch from Eric Lemar (via Ian Soboroff): in suspend and resume, 
 *      fix wrong cast from pci_dev* to struct trident_card*. 

 *  v0.14.10e
 *      July 19 2002 Muli Ben-Yehuda <mulix@actcom.co.il>
 *      rewrite the DMA buffer allocation/deallcoation functions, to
make it 
 *      modular and fix a bug where we would call free_pages on memory 
 *      obtained with pci_alloc_consistent. Also remove unnecessary
#ifdef 
 *      CONFIG_PROC_FS and various other cleanups.
 *  v0.14.10d
 *      July 19 2002 Muli Ben-Yehuda <mulix@actcom.co.il>
 *      made several printk(KERN_NOTICE...) into TRDBG(...), to avoid
spamming
 *      my syslog with hundreds of messages. 
[..]
------------------

No, thank you for fixing drivers :-).
Comment 8 Muli Ben-Yehuda 2004-01-18 10:33:37 EST
Great, it appears to be the stock 2.4 driver. The 2.6 has a few
cleanups and fixes, but I'd rather not apply them to 2.4 at this
stage. Arjan, I think you can close the bug... 

Note You need to log in before you can comment on or make changes to this bug.