Bug 77643 - (440GX IRQ_ROUTING)Intel L440GX+ aic7xxx module failure (apic thing)
(440GX IRQ_ROUTING)Intel L440GX+ aic7xxx module failure (apic thing)
Status: CLOSED DUPLICATE of bug 79752
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-11-11 05:03 EST by Tim Bates
Modified: 2007-04-18 12:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Bates 2002-11-11 05:03:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Same problem as what everyone with these motherboards has had with 7.x, but the 
trick with adding apic to the kernel params doesnt work anymore (in 8.0).

Using the SMP kernel doesnt fix it, using single cpu kernel with APIC option 
doesnt work either.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Use a Intel L440GX+ Motherboard
2.Install redhat 8.0 (may need to use APIC kernel option to get installer to 
start, I dont remember)
3. Start newly installed system.

Actual Results:  The aic7xxx module waits about 5-10 seconds, spits out hex 
garbage (not gonna put that here cause I dont want to type it all) and then 
says stuff like:

Is not an active device
Command already completed
not ready or command retry failed after bus reset: host x channel x id x lun x

Expected Results:  System boot normally.

Additional info:
Comment 1 Charles Roberts 2003-01-30 20:55:40 EST
  I'm also trying to run this down.  I have found that 8.0 runs fine if you 
have two processors.  I tried to fake it out and remove one - NO GO.

  I suppose I could pick up a pair of PIII 600's on ebay for $150, but I also 
know that SuSE 8.0 and 8.1 run on these, with one processor, JUST FINE.  From 
power up to completely installed - no problems.

  Several threads call this a 'bios bug' from Intel and write it off as "Linux 
2.4 un-friendly".  I don't buy it.  If it were then SuSE would not work and 
RedHat 8.0 would not work with 2 processors.

  I went through this with 7.2 (the fake-out by pulling a processor worked on 
7.2) and had much higher hopes for 8.0.  Wasted money, I guess.

C Roberts


Comment 2 Tom Diehl 2003-02-03 10:37:07 EST
All you have to do is recompile the kernel with the following changes:  
1. compile for PIII support 
2. Enable local APIC support for uniprocessors 
3. Enable IO-APIC support for uniprocessors 
It works fine on 1 cpu for me and others. I even built rpms from RedHat's spec 
file for it, since I have multiple machines. Arjan has said in the past that 
Red Hat does not enable these options because it breaks a LOT of laptops. I 
guess SuSe does not care or else they know something Red Hat does not. 
Comment 3 Jason Dixon 2003-04-01 08:24:02 EST
I have confirmed that this "fix" works for Red Hat 7.2 as well, on a
uniprocessor L440GX+ board.  
Comment 4 Jason Dixon 2003-04-01 08:25:34 EST
Shoot, forgot to mention that this was used to create an updated (2.4.18-27.7.x)
kernel on an updated 7.2 system.  Props to Tom Diehl for solving this one.
Comment 5 Benjamin Scott 2003-05-06 22:05:42 EDT
See also Bug 78234, which appears to be a duplicate of this bug, but has more
Comment 6 Alan Cox 2003-06-08 07:29:04 EDT

*** This bug has been marked as a duplicate of 79752 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:50:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.