Bug 77649 - Evolution does not display GB2312 (Simplified Chinese) encoded messages.
Evolution does not display GB2312 (Simplified Chinese) encoded messages.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-11 09:05 EST by phostetl
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 19:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description phostetl 2002-11-11 09:05:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20021108

Description of problem:
Evolution does not display GB2312 (Simplified Chinese) e-mail.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Created Simplified Chinese e-mail using Mozilla sent to self.
2. Open message with Mozilla -- looks OK.
3. Open message with evolution -- no GB2312 characters displayed.  Selecting the
Character Encoding manually did not correct the problem.
	

Actual Results:  Email GB2312 characters are not displayed.

Expected Results:  Email GB2312 characters are detected automatically and
displayed properly.

Additional info:
Comment 1 phostetl 2002-11-11 09:42:51 EST
This bug report at Ximian is a duplicate:

http://bugzilla.ximian.com/show_bug.cgi?id=31780
Comment 2 Jeremy Katz 2002-11-22 12:20:05 EST
Quite possibly due to the font you have chosen for display not having gb2312
coverage.  You might want to try choosing different fonts in the gtkhtml font
configuration to see if that helps.
Comment 3 Jeremy Katz 2003-02-09 22:03:34 EST
Is this any better with Phoebe?
Comment 4 phostetl 2003-04-09 11:10:23 EDT
No change with Red Hat 9 (release).  I can even log in with the environment set
to Simplified Chinese and no luck.

The Simplified Chinese messages do display properly in the Mozilla 1.3 mail client.
Comment 5 Jeremy Katz 2003-07-28 19:15:22 EDT
evolution 1.4 handles this much better since it uses gtk2 and pango

Note You need to log in before you can comment on or make changes to this bug.