Bug 77661 - gnome-panel crashes when panel moved
gnome-panel crashes when panel moved
Status: CLOSED DUPLICATE of bug 75138
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-11 12:04 EST by Ljubomir J. Buturovic
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-11 12:04:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ljubomir J. Buturovic 2002-11-11 12:04:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1) Gecko/20020827

Description of problem:
If gnome-panel is moved from its' default position at the bottom of the screen,
Gnome crashes and gets into unusable state. Subsequent attempts to do startx
take half an hour, finishing again in the unusable state. The workarounds are:
1) switchdesk kde 2) remove .gconf, .gconfd, .gnome, .gnome2 files and restart
startx.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat 8.0.
2. startx
3. Move gnome-panel from the default position, for example to the left side of
the screen.
	

Actual Results:  Gnome crashes, tries to start, then crashes again, etc. The
desktop is unusable.

Expected Results:  Move the panel correctly.

Additional info:

Already submitted to bugzilla.gnome.org by dozens of people (bug ID 94625). I
believe they have a fix.
Comment 1 Havoc Pennington 2002-11-11 22:22:17 EST
Yes, I caused the bug, and wrote the fix also. ;-)


*** This bug has been marked as a duplicate of 75138 ***
Comment 2 Havoc Pennington 2002-11-11 22:23:40 EST
Note that the simple workaround is to only remove panel config, remove 
.gconf/apps/panel. You can even be a lot more precise than that (go in there
with vi or into gconf-editor and just change the "orientation" value of the
panel that has the notification area applet on it)
Comment 3 Ljubomir J. Buturovic 2002-11-12 12:44:50 EST
Hi,

The workaround does not work. Neither does the workaround 2) in the original
report. They work for a couple of logins, but after that the subsequent logins
take a long time (half an hour or so), and the panel is not there. The only
thing that works is to switch to KDE, at least in my environment.

Ljubomir

Note You need to log in before you can comment on or make changes to this bug.