Bug 77692 - nameserver out of sync with redhat-config-network when caching NIS
nameserver out of sync with redhat-config-network when caching NIS
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-12 01:15 EST by George Karabin
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-18 23:36:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Karabin 2002-11-12 01:15:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021104

Description of problem:
The nameserver used by the system can get out of sync with the list of DNS
servers specified by a redhat-config-network profile. This appears to happen
when "caching" is enabled by authconfig-gtk.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Logged into a network using NIS and ypbind, "caching" enabled via authconfig-gtk.
2. Shut down laptop.
3. Moved laptop to a new network without NIS, powered up.
4. ypbind failed to attach to a server as expected and timed out
5. Logged in using NIS cached authentication
6. Switched to a new network profile using redhat-config-network-cmd that
automatically used new DNS servers



Actual Results:  nslookup can see new DNS server as expected. mozilla, ftp, and
other programs try to use old DNS server (on unreachable network), and don't
resolve addresses.


Expected Results:  All programs should use new DNS settings.


Additional info:

I noticed that authconfig-gtk had added "nis" to the "hosts" line before the
"dns" entry when I enabled caching. I think that this may be the cause of the
problem, because disabling caching from authconfig-gtk made the problem go away.
re-enabling caching hasn't caused a problem, but I haven't yet returned to the
network that I use NIS on (it's at work). I'll post if I can reproduce the problem.

Enabling caching from an authentication configuration program shouldn't have the
effect of also caching the DNS server to use (at least, that's what appeared to
be happening). One final thought - maybe this is really a glibc/nscd issue, and
enabling nis lookup of hosts shouldn't affect which nameserver(s) are used. I
don't know enough about what that pair of packages does to say.
Comment 1 Jakub Jelinek 2002-11-12 11:32:38 EST
If you're using nscd, you obviously have to restart nscd if you change DNS
or nsswitch settings.
Maybe redhat-config-network should do this for you...
Comment 2 George Karabin 2002-11-18 23:36:13 EST
Yeah, I hadn't restarted nscd. That fixes it - thanks!
Comment 3 Harald Hoyer 2002-11-19 06:32:30 EST
hmm, one should restart all network services, after switching profiles...

Note You need to log in before you can comment on or make changes to this bug.