Bug 777 - using threaded libraries with the stock python distribution
using threaded libraries with the stock python distribution
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-11 03:37 EST by James Henstridge
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-18 17:08:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Henstridge 1999-01-11 03:37:53 EST
If you use an extension module that links with libpthread,
problems related to errno occur (this is because some of the
code will use the normal single threaded errno variable, and
code loaded after pthread uses (*__errno_location()).

These problems can be fixed by LD_PRELOADing libpthread or
by building thread support into python.  The second option
is easier for users, and also allows threaded python
programs to run out of the box on redhat systems.

I have only just started to see these problems while
developing pygtk and gnome-python packages (since GTK
recently became threaded).  If you intend to include
gnome-python with the GNOME distribution, this change will
be needed to make gnome-python usable.
Comment 1 Bill Nottingham 1999-03-18 17:08:59 EST
fixed in a later python release

Note You need to log in before you can comment on or make changes to this bug.