Bug 77735 - forgets POP3 password on transient error
forgets POP3 password on transient error
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-12 17:10 EST by Tim Waugh
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-20 00:24:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-11-12 17:10:47 EST
Description of Problem:
Sometimes I see this message:

Unable to connect to POP server.
Error sending password: mail storage services unavailable, wait a few miunutes
and try again.

Then it prompts me for the password.  After 'cancel', future attempts to
send/receive mail just prompt for the password; it has apparently forgotten it!
Comment 1 Jim 2002-11-14 18:52:07 EST
This occurs to my system which is a RH8 with i386 running evolution email with
KDE as my desktop.  It is a sporadic problem that I can't casue to happen. 
Sometimes I can't get evolution to accept my pop3 password and sometimes it
does.  I've exited xwindows, logged out, shutdown and rebooted the system. 
Sometimes it works, but usually it doesn't.  It appears to resolve itself and
works for several days.  I noticed this first with my initial evolution version
and it was still seen after I updated several days ago to version 1.2.0
Comment 2 Jeremy Katz 2002-11-22 12:20:36 EST
This is an intentional design decision.  If there is an error, it could well be
because of an incorrect password and so evolution forgets your password at that
point.
Comment 3 Tim Waugh 2002-11-22 12:23:33 EST
It's a bad decision then.  This can happen for entirely transient reasons.

Why not give it a couple of attempts or something?  Or look at the message and
figure out if it's a transient error.
Comment 4 Jim 2002-12-01 09:35:52 EST
This is a transient problem.  I enter in the correct pop3 password each time. 
And it will accept that password on some occasions, but not on others.  And when
it does accept the password as correct, then maybe somebody can explain why this
password is not accepted in the future.  This indicates a problem with the
storage of the password that is transient in nature and may reflect a corruption
of this password.  After I upgraded the version of evolution to 1.2.0 the
problem with the password does not occur very frequently.  I think that my
system will go for a week to ten days with any need for me to reenter the
correct password again.  

Let katzj know that this is not due to my entering in a correct password, but it
is something buggy with evolution, rh 8 or the combination.
Comment 5 Tim Waugh 2003-02-05 15:04:30 EST
In my case, the error message even says 'try again in a few minutes'.
Comment 6 Jeremy Katz 2003-02-05 17:48:04 EST
Unfortunately, it's an error message that could be possibly localized and
differs for every POP server on the planet.  It's just not something that's
reasonable to fix
Comment 7 Tim Waugh 2003-02-05 18:25:37 EST
Huh?  Sure it's reasonable to fix.  Here's some very reasonable behaviour:

Disable automatic send/receive for that session only.

(This is exactly what the gnome-panel applet does in the very same situation; I
don't have to continually refresh its memory about the password.)
Comment 8 Jeremy Katz 2003-02-20 00:24:54 EST
Jeff was convinced to make some changes upstream, but they were deemed too large
for backporting to 1.2.x since they depend on some newer infrastructure in the
gnome2 port
Comment 9 Tim Waugh 2003-05-16 12:56:23 EDT
Current 1.3.x fixes this.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.