Bug 77771 - redhat-config-soundcard does not write any configuration
redhat-config-soundcard does not write any configuration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-soundcard (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-13 08:00 EST by Gerald Teschl
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-13 08:01:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2002-11-13 08:00:54 EST
I tried r-c-s on two different boxes with two different pci
sound cards:

VIA Technologies, Inc. VT82C686 AC97 Audio Controller
Ensoniq 5880 AudioPCI

Both sound cards work fine when configured manually.

On both boxes I get the same results:

1) It dedects the sound card properly and listst the correct driver.
2) It fails to play the test sound (not surprising since according
to demsg/lsmod it never even tries to load the module)
3) It does not write any configuration.

If I load the proper sound module before running redhat-config-soundcard
it will play the test sound, but it will still not write anything to
/etc/modules.conf.

There are no errors displayed.

What is this tool supposed to do? Just display the sound driver and play
a test sound when the user has loaded the driver manually? Then why is
it called "config" if it does not write any configuration.
Comment 1 Brent Fox 2002-11-22 13:55:44 EST
In the first iteration, it was bascially a way to show the user in firstboot
that the soundcard had been detected and was functional.  I have just completed
some new code that actually configures the cards.  Also, I've added more code
that handles multiple soundcards better.  You can now choose which card you want
to be the default soundcard (/dev/dsp).  Since most apps send sound to /dev/dsp,
this will allow you to choose which card you want to be the default.

Should exist in redhat-config-soundcard-1.0.2-1 and should appear in Rawhide in
the next day or so.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.