Bug 77772 - ks fails to dedect lba
ks fails to dedect lba
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-13 08:10 EST by Gerald Teschl
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 00:24:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2002-11-13 08:10:57 EST
I use ks and lilo (since grub does not work for us):

# bootloader
bootloader --location mbr --useLilo

However, anaconda always writes "linear" instead of "lba32" to
lilo.conf. Moreover, lilo detects that "linear" is nonsense and
fails to install. However, anaconda seems to completely ingore
these errors and finishes "normally" leaving a system without
bootmanager.
Comment 1 Jeremy Katz 2002-11-14 19:06:00 EST
What is the output of lilo with linear in the config file?  Unfortunately, lba32
can't always be reliably detected (hence why there's the forcelba option)
Comment 2 Gerald Teschl 2002-11-16 11:19:29 EST
The lilo output is:

Fatal: sector 68686864 too large for linear mode (try 'lba32' instead)

and should be easy to dedect;-)


Comment 3 Jeremy Katz 2002-11-26 17:13:00 EST
Right, but that doesn't mean that lba32 will work.  Does it actually boot if you
change it to lba32?  Also, what is the output of the following run as root with
the booty package installed?

PYTHONPATH=/usr/lib/booty/ python  -c "import edd;print edd.detect()"
Comment 4 Gerald Teschl 2002-11-27 11:54:24 EST
Sure, but since you can't even install the boot loader with linear, what
can you loose;-)

Yes lba32 does work (this is brand new hardware with a 40G hard drive).

The output is "0".
Comment 5 Jeremy Katz 2002-12-11 17:42:38 EST
(also, note that you can force lba32 with --lba32 on your boot loader line... 
but on new hardware, it really should be detected properly)
Comment 6 Jeremy Katz 2003-01-03 00:24:29 EST
It looks like the edd detection code is segfaulting on most of my machines (it
works on the thinkpad, but that's it).  The best way to get working LBA32 is
going to be to either a) explicitly specify that you need it in kickstart or b)
use grub which will detect if you can use lba32 at boot time and thus not be
constrained by the kernel trying to keep people from hacking systems via the
vm86 stuff.
Comment 7 Gerald Teschl 2003-01-03 04:28:02 EST
I understand, that this is low priority for you, but if
lilo dedects that linear is wrong and lba32 should be used,
then where is the problem. Parsing the output for the above
error if lilo fails and trying again with lba32 instead
should be straight forward.

As I already mentioned, grub does not work for us. We absolutely
need "lilo -R" and as long as grub does not offer the equivalent,
it is no option for us.


Note You need to log in before you can comment on or make changes to this bug.