Bug 777737 (SOA-253) - Error on Processing Image of an started process on the jBPM console
Summary: Error on Processing Image of an started process on the jBPM console
Keywords:
Status: CLOSED WORKSFORME
Alias: SOA-253
Product: JBoss Enterprise SOA Platform 4
Classification: JBoss
Component: JBPM - within SOA
Version: 4.2 Beta 1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.2 CR3
Assignee: Koen Aers
QA Contact:
URL: http://jira.jboss.org/jira/browse/SOA...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-21 18:23 UTC by Jehudi Castro Sierra
Modified: 2013-01-11 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
RHEL5, jboss-soa-p-standalone
Last Closed: 2008-01-18 18:24:22 UTC
Type: Bug


Attachments (Terms of Use)
error-jbpm.png (126.50 KB, image/png)
2007-12-21 18:24 UTC, Jehudi Castro Sierra
no flags Details
processDefinition.tar.gz (11.58 KB, application/x-gzip)
2008-01-14 08:42 UTC, Jehudi Castro Sierra
no flags Details
server.log.tar.gz (475.32 KB, application/x-gzip)
2008-01-14 11:56 UTC, Jehudi Castro Sierra
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 777817 None None None Never
Red Hat Bugzilla 777818 None None None Never
Red Hat Bugzilla 777819 None None None Never
Red Hat Issue Tracker SOA-253 None None None Never

Internal Links: 777817 777818 777819

Description Jehudi Castro Sierra 2007-12-21 18:23:35 UTC
Date of First Response: 2008-01-08 10:11:39
project_key: SOA

1. Run the bpm_orchestration1 quickstart
2. Enter to the jBPM console, examine the process, start the process
3. Enter to the Process Image

Get the message: Error getting diagram info: An exception of type "java.lang.NullPointerException" was thrown.

See logs attached.
Console output:
18:41:37,073 ERROR [Services] problem closing service 'persistence'
org.jbpm.JbpmException: setRollbackOnly was invoked while configuration specifies user managed transactions
        at org.jbpm.persistence.db.DbPersistenceService.close(DbPersistenceService.java:206)
        at org.jbpm.persistence.jta.JtaDbPersistenceService.close(JtaDbPersistenceService.java:34)
        at org.jbpm.svc.Services.close(Services.java:225)
        at org.jbpm.JbpmContext.close(JbpmContext.java:139)
        at org.jbpm.jsf.core.phase.JbpmPhaseListener.closeContext(JbpmPhaseListener.java:94)
        at org.jbpm.jsf.core.phase.JbpmPhaseListener.afterPhase(JbpmPhaseListener.java:45)
        at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:280)
        at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)
        at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
        at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
        at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
        at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:241)
        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
        at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:580)
        at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
        at java.lang.Thread.run(Thread.java:595)
18:41:37,074 ERROR [CachedConnectionValve] Application error: Faces Servlet did not complete its transaction

Comment 1 Jehudi Castro Sierra 2007-12-21 18:24:39 UTC
Attachment: Added: error-jbpm.png


Comment 2 Koen Aers 2008-01-08 15:11:39 UTC
Can you try to reproduce this with the latest jbpm-jpdl suite release? i.e. 3.2.2

Can you try to do that and attach the process definition information if this is the case?

Comment 3 Jehudi Castro Sierra 2008-01-14 08:41:41 UTC
The version of the jbpm-jpdl suite used by the JBoss SOA Platform - Version 4.2.0.beta1 is 3.2.2

Comment 4 Jehudi Castro Sierra 2008-01-14 08:42:36 UTC
process definition information

Comment 5 Jehudi Castro Sierra 2008-01-14 08:42:36 UTC
Attachment: Added: processDefinition.tar.gz


Comment 6 Koen Aers 2008-01-14 09:43:50 UTC
1. Are you sure that all the classes that are referenced in your process definition are on the classpath? More in particular the referenced actions and their dependent classes.
2. Can you attach the log file that was produces by the server. The stacktrace above is probably a result of some other error happening earlier.

Comment 7 Jehudi Castro Sierra 2008-01-14 10:24:25 UTC
The server is no complaining about any missing class, so I guess that the classpath is OK. Anyway if there is a problem with the process definition, this is a quickstart (bpm_orchestration1) bug.
This is the console output between the deployment of the Process Definition and the exception:

10:58:24,395 INFO  [CommandExecutor] Process Definition 'processDefinition2' is deployed.
10:58:24,412 WARN  [ActionProcessingPipeline] No reply to address defined for reply message! To: FileEpr [ PortReference < <wsa:Address file:/home/jcastros/Projects/SOA/BETA1/soa-4.2.0/jboss-soa-p.4.2.0/jboss-as/samples/quickstarts/bpm_orchestration1/build/inputdir//>, <wsa:ReferenceProperties jbossesb:inputSuffix : .deployProcessESB/>, <wsa:ReferenceProperties jbossesb:errorDelete : true/>, <wsa:ReferenceProperties jbossesb:errorDir : /home/jcastros/Projects/SOA/BETA1/soa-4.2.0/jboss-soa-p.4.2.0/jboss-as/samples/quickstarts/bpm_orchestration1/build/inputdir//>, <wsa:ReferenceProperties jbossesb:errorSuffix : .esbERROR/>, <wsa:ReferenceProperties jbossesb:postDelete : true/>, <wsa:ReferenceProperties jbossesb:postDir : /home/jcastros/Projects/SOA/BETA1/soa-4.2.0/jboss-soa-p.4.2.0/jboss-as/samples/quickstarts/bpm_orchestration1/build/inputdir//>, <wsa:ReferenceProperties jbossesb:postSuffix : .esbDONE/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/file/> > ] MessageID: 1e68d9f9-0fda-43ce-a658-f81a1d6bd3ba
10:59:13,630 ERROR [Services] problem closing service 'persistence'
org.jbpm.JbpmException: setRollbackOnly was invoked while configuration specifies user managed transactions
...

Comment 8 Koen Aers 2008-01-14 10:29:03 UTC
Your assumptions are wrong, it is not because the deployment is ok that all the classes are available on the classpath.

Please do what I asked for and upload the complete log file. It is impossible to analyze the error otherwise.

Comment 9 Jehudi Castro Sierra 2008-01-14 11:56:14 UTC
attaching complete log file

Comment 10 Jehudi Castro Sierra 2008-01-14 11:56:14 UTC
Attachment: Added: server.log.tar.gz


Comment 11 Koen Aers 2008-01-14 12:44:20 UTC
Ok, the error indicates that you are using a wrong configuration for jbpm. You probably invoke setRollbackOnly somewhere in the code of one of your action handlers while your configuration indicates that you are using user managed transactions. Either update the configuration to use container managed transactions or update your actionhandler code to invoke a rollback on the transaction instead of a setRollbackOnly.

Comment 12 Koen Aers 2008-01-14 12:53:11 UTC
Btw, I couldn't find you initial error message (Error getting diagram info: An exception of type "java.lang.NullPointerException" was thrown) in the logfile. Please make sure that you reproduce the same exact behaviour and then post the corresponding log file.

Comment 13 Jehudi Castro Sierra 2008-01-14 14:14:29 UTC
In that case bpm_orchestration1 quickstart is broken, should work out of the box.
the "java.lang.NullPointerException" appears on the page, as you can see in the attached screen capture, but no in the logs.

Comment 14 Mark Little 2008-01-14 17:29:41 UTC
If this issue is against the Quickstart now then close this issue and open a new one.

Comment 15 Len DiMaggio 2008-01-18 17:49:27 UTC
Link: Added: This issue related SOA-343


Comment 16 Len DiMaggio 2008-01-18 18:24:22 UTC
I'm closing this JIRA in favor of opening a new JIRA for this quickstart.

Comment 17 Len DiMaggio 2008-01-18 18:36:38 UTC
Link: Added: This issue related SOA-344


Comment 18 Len DiMaggio 2008-01-18 20:37:29 UTC
Link: Added: This issue related SOA-345


Comment 19 Len DiMaggio 2008-03-02 03:13:09 UTC
Link: Added: This issue is a dependency of SOA-446



Note You need to log in before you can comment on or make changes to this bug.