This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 77790 - Helvetica "normal" font does not display properly but helvetica "bold" does with remote X-client gnumeric
Helvetica "normal" font does not display properly but helvetica "bold" does w...
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gnumeric (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-13 12:16 EST by Glen A. Foster
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 22:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
normal helvetica size 9 (17.55 KB, image/png)
2002-11-13 13:04 EST, Michael Lee Yohe
no flags Details
bold helvetica size 9 (17.64 KB, image/png)
2002-11-13 13:04 EST, Michael Lee Yohe
no flags Details
gnumeric across X with font information... (37.21 KB, image/png)
2002-11-13 15:27 EST, Michael Lee Yohe
no flags Details

  None (edit)
Description Glen A. Foster 2002-11-13 12:16:30 EST
Description of Problem: SSIA.

Version-Release number of selected component (if applicable):
# rpm -q gnumeric
gnumeric-1.0.9-2

How Reproducible: 100% (always)

Steps to Reproduce:
1. Create a new spreadsheet, set font to "helvetica", 9-point
2. Type text in cell and note the "squares" next to each char typed
3. Press return, re-select the cell with the text, and press the B (bold) button

Actual Results: Bold displays properly, normal text does not

Expected Results: It all displays properly
Comment 1 Glen A. Foster 2002-11-13 12:23:46 EST
FWIW, gnumeric-1.0.5-3 (shipped with 7.3/Valhalla) does not have this problem.
Comment 2 Michael Lee Yohe 2002-11-13 13:03:40 EST
I am not seeing this problem.  Please see image attachments.

$ rpm -q gnumeric
gnumeric-1.0.9-2
Comment 3 Michael Lee Yohe 2002-11-13 13:04:29 EST
Created attachment 84864 [details]
normal helvetica size 9
Comment 4 Michael Lee Yohe 2002-11-13 13:04:58 EST
Created attachment 84866 [details]
bold helvetica size 9
Comment 5 Glen A. Foster 2002-11-13 13:54:45 EST
Oops, you're right.  If I run gnumeric locally on my x86 box, this works fine. 
I've updated the defect summary to reflect this now.

I can re-create the reported behavior as follows:

(1) Install Advanced Workstation 2.1 on an HP zx2000 (Itanium-2) and login to X
(2) run "xhost +"
(3) ssh to an x86 host running 8.0
(4) run gnumeric (displays the window/widget(s) back on the zx2000)

... and viola.  There's the ugly behavior.

Thanks for helping make this defect report more accurate!
Comment 6 Michael Lee Yohe 2002-11-13 15:26:29 EST
You may have to re-do the summary again.  I've just ran gnumeric with a remote
X-client and had no problems with the fonts (see attachment).  Are you sure the
fonts you are using aren't corrupted on the server machine?
Comment 7 Michael Lee Yohe 2002-11-13 15:27:21 EST
Created attachment 84906 [details]
gnumeric across X with font information...
Comment 8 Glen A. Foster 2002-11-13 17:57:42 EST
Perhaps it *is* the server-side.  That would be Advanced Workstation 2.1 for
IA64.  Changing platform, version, and product to reflect this.
Comment 9 Mike A. Harris 2002-11-13 18:33:23 EST
Red Hat Linux 8.0 uses client side fonts by default for GNOME2/KDE/GTK2 apps.
So when you ssh to the 8.0 box, if gnumeric is GTK2 based (I haven't checked),
then it is using fonts stored on the 8.0 box.  Your 2.1 box's fonts are
not available to gnumeric in this case.

If gnumeric is not using Xft, then it is using server side fonts on the 2.1AS
box.  I don't have gnumeric installed and handy right now or I would check.
Comment 10 Mike A. Harris 2002-11-13 18:38:34 EST
I just checked in beehive, and gnumeric from 8.0 is using gnome 1.x and
gtk 1.x so it is using X server fonts.  The font problem is most likely
then on your X server side.
Comment 11 Glen A. Foster 2002-11-14 10:00:19 EST
I can believe it's related to the X server.  I can reproduce this behavior IFF
the X server is running on the recently-released Advanced Workstation 2.1
release for IPF (Itanium-2) boxes.  I've done it on a Longs Peak (HP zx2600) and
Wilson Peak (HP zx2000) workstation, using an x86 8.0 system to run the gnumeric
client.

These were "everything" installs.
Comment 12 Mike A. Harris 2002-12-18 23:17:18 EST
Not sure what the problem could be, but I've added Owen for comment.
Comment 13 Owen Taylor 2002-12-19 11:12:00 EST
Basically, this is a sign of the app trying to use a font that doesn't
agree with the locale. If you try to use, say, "fixed" as a font for 
the UTF-8 locale, then the X library guesses that the encoding for the
font is iso10646-1, and renders as if it were a two byte font, even though
it is actually a one byte font. Hence the boxes.

So, probably what I'd guess is that the problem is that the fonts that
Gnumeric is trying to use aren't present on the target box, so font
rendering falls back to "fixed".

(In Red Hat 8, I'm not sure what gnumeric is using by default; my memory
is that it is hideously ugly)
Comment 14 Mike A. Harris 2002-12-21 09:42:03 EST
Owen:  So are you concluding this is NOTABUG?
Comment 15 Owen Taylor 2002-12-21 22:43:05 EST
It's probably a bug , but I'm not sure it's a *fixable* bug. I'd suggest
a reassign to gnumeric, though it may really be a gnome-print thing
in the end.

The immediate cause here may well be missing fonts on the system where 
the text is being displayed, but the fallback should be more graceful
and shouldn't end up with the boxes.

I have a suspicion that this will probaly won't be really fixed until
gnumeric gets switched over to Xft and fontconfig.
Comment 16 Mike A. Harris 2002-12-22 03:39:51 EST
Ok, thanks for the input Owen.  Reassigning to gnumeric.
Comment 17 Havoc Pennington 2002-12-22 12:10:55 EST
I've basically been told by upstream Gnumeric that fixing UTF-8 in 
the 1.0.x series is too hard and it'll be repaired in 1.2
Comment 18 Havoc Pennington 2003-01-12 22:00:16 EST
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103297

Note You need to log in before you can comment on or make changes to this bug.