Bug 77803 - ping gives warning: time of day goes back
ping gives warning: time of day goes back
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Mike McLean
:
Depends On: 77861
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-13 16:05 EST by Hrunting Johnson
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-03 10:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hrunting Johnson 2002-11-13 16:05:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
When pinging hosts, intermittently, the error 'Warning: time of day goes back, 
taking countermeasures.'  Countermeasures, in this case, appears to be 
returning a trip time of 0 usecs.

I just recently upgraded the machine from kernel-2.4.9-31 to kernel-2.4.18-
17.7.x (both RH7.2 errata kernels, stock).  The problem did not exist before 
the upgrade.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. upgrade kernel
2. ping -U -s 56 host 10
3.
	

Actual Results:  Warning given, ping returns bad 0 value for the time.  After 
first return, subsequent warnings take a long time (> 5secs) to appear.

Expected Results:  Ping doesn't give warning and gives correct ping times.

Additional info:

This bug has been filed under 19952 (CLOSED) for RH7.0 and as a duplicate of 
that bug (60765) for RH 7.2.  I'm filing separately because the old bug has 
been closed for over six months, and the kernel was released in October.  This 
may be different issue, or it may be a regression, but I want it seen.
Comment 1 Hrunting Johnson 2002-11-13 17:34:56 EST
I upgraded to the latest rawhide version of iputils (I normally don't like to 
upgrade past anything outside the distro and its errata, but I really need 
this), and the warnings have gone away (presumably because they're only printed 
in verbose mode now; see changelog).

I'm still extremely nervous about those 0usec ping times, though, when the 
errors was printed.  We're measuring ping times for latency calculations, so 
0usec ping times are actually a big deal to us.
Comment 2 Hrunting Johnson 2002-11-13 17:39:31 EST
Example output showing what we're seeing, even with the new code:

$ ping -U -v -s 56 209.99.41.93
PING 209.99.41.93 (209.99.41.93) from 216.166.60.79 : 56(84) bytes of data.
64 bytes from 209.99.41.93: icmp_seq=1 ttl=254 time=0.609 ms
64 bytes from 209.99.41.93: icmp_seq=2 ttl=254 time=0.756 ms
64 bytes from 209.99.41.93: icmp_seq=3 ttl=254 time=0.664 ms
64 bytes from 209.99.41.93: icmp_seq=4 ttl=254 time=0.635 ms
64 bytes from 209.99.41.93: icmp_seq=5 ttl=254 time=0.744 ms
64 bytes from 209.99.41.93: icmp_seq=6 ttl=254 time=0.906 ms
64 bytes from 209.99.41.93: icmp_seq=7 ttl=254 time=0.616 ms
64 bytes from 209.99.41.93: icmp_seq=8 ttl=254 time=0.695 ms
64 bytes from 209.99.41.93: icmp_seq=9 ttl=254 time=0.634 ms
64 bytes from 209.99.41.93: icmp_seq=10 ttl=254 time=0.720 ms
Warning: time of day goes back (-7806011us), taking countermeasures.
64 bytes from 209.99.41.93: icmp_seq=11 ttl=254 time=0.000 ms
Warning: time of day goes back (-7806078us), taking countermeasures.
64 bytes from 209.99.41.93: icmp_seq=12 ttl=254 time=0.000 ms
64 bytes from 209.99.41.93: icmp_seq=13 ttl=254 time=0.722 ms
64 bytes from 209.99.41.93: icmp_seq=14 ttl=254 time=0.833 ms
64 bytes from 209.99.41.93: icmp_seq=15 ttl=254 time=0.630 ms
Comment 3 Phil Knirsch 2003-05-15 06:47:49 EDT
Do you have ntp running on that host by chance? This might affect the time
setting of your machine and cause the effect. With the latest iputils on a RH 9
i haven't see the effect at all anymore (where i was able to reproduce it with
older releases and kernels).

As you've been using the latest iputils package i can only think of 2 causes:
either ntp running on your machine or that the 7.2 errata kernel still has
issues with the precise time interface.

Read ya, Phil
Comment 4 Phil Knirsch 2003-09-03 10:10:46 EDT
I've tried various setups and installations over the last few months and the bug
didn't appear on any of the systems anymore, so i'm closing the bug as fixed in
the current release.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.