Bug 77811 - Error in kickstart docs
Error in kickstart docs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhl-cg (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-13 17:51 EST by Brent Fox
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-14 23:39:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Fox 2002-11-13 17:51:24 EST
I think that the docs for the "--append" option for the bootloader command is
missing a "=". 

If you look in kickstart.py from anaconda:

        (args, extra) = isys.getopt(args, '',
                [ 'append=', 'location=', 'useLilo', 'lba32',
                  'password=', 'md5pass=', 'linear', 'nolinear',
                  'upgrade'])

It looks like the 'append' tag needs an "=".  It's also not clear what the
proper syntax for the kernel parameters is supposed to be.  

For example: 
1) Do I need to put the parameters in quotation marks?  Probably not, but it's
not clear.

2) If there's more than one, do they need to be comma separated?  Or does each
additional parameter need another "append" tag like:
bootloader --append=nodma --append=noapic

We need more information.  Note: I'm not sure what the correct answer is here. 
Maybe check with katzj.
Comment 1 Tammy Fox 2002-11-14 23:39:46 EST
I was told that you can use the = or not. I'll test it and let you know.
Comment 2 Tammy Fox 2002-12-12 16:39:08 EST
katzj said the syntax is:

--append="foo bar baz" 

I added an explanation of how to specify multiple parameters and an example.
It will appear in the next version.

Note You need to log in before you can comment on or make changes to this bug.