Bug 77825 - GNOME hangs upon login splash screen
GNOME hangs upon login splash screen
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-13 20:16 EST by Jack M. Nilles
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 19:26:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of rpm -qav (15.14 KB, text/plain)
2002-11-20 14:05 EST, Jack M. Nilles
no flags Details
output of rpm -aV (22.92 KB, text/plain)
2002-11-20 14:06 EST, Jack M. Nilles
no flags Details

  None (edit)
Description Jack M. Nilles 2002-11-13 20:16:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

Description of problem:
I upgraded to 8.0 from 7.3. Now, when any user logs in via GNOME the splash
screen comes up, without any icons in its lower section. No amount of mouse
clicking will produce further results. Ctl-alt-backspace will get back to level
3. The screen then shows an error message: 'GNOME not found'or similar--I don't
have it in front of me. startx simply gets back to the same impasse. The only
way I've found to get out of this is to reboot, a la Windows, and login via KDE.

Version-Release number of selected component (if applicable): 2.4.0.7-13


How reproducible:
Always

Steps to Reproduce:
1.enter user name (any user)
2.enter password
3.
	

Actual Results:  As in the description above

Expected Results:  An active, utile GNOME desktop

Additional info:

gedit also will not work either in GNOME--since I can't get there--or KDE. There
may be other broken links but mostly they relate to the "upgrade" not
eliminating older versions of packages.
Comment 1 Jack M. Nilles 2002-11-19 18:41:58 EST
The exact message when I ctl-alt-backspace to level 3 is:
/etc/X11/prefdm: line 1: GNOME: command not found
This led to a review of prefdm which, in turn led to /etc/sysconfig/desktop.
The only line in desktop was: GNOME.
I compared that with another macine running RH 8.0 and changed it from
GNOME to DESKTOP=""
Unfortunately, this had no effect. I still had to reboot and go to KDE to get
back in operation.
Comment 2 Havoc Pennington 2002-11-19 18:56:11 EST
That isn't a valid value of /etc/sysconfig/desktop (and shouldn't have been
written out), though an invalid value there doesn't explain a hang, perhaps 
the same problem that resulted in an invalid value there also resulted 
in the hang.

Can you attach the output of "rpm -qav" and "rpm -Va"
Comment 3 Jack M. Nilles 2002-11-20 14:05:35 EST
Created attachment 85740 [details]
results of rpm -qav
Comment 4 Jack M. Nilles 2002-11-20 14:06:51 EST
Created attachment 85741 [details]
output of rpm -aV
Comment 5 Havoc Pennington 2002-11-20 14:38:07 EST
Just a shot in the dark, what has changed about this file vs. the stock 
8.0 version:
S.5....T c /etc/X11/xdm/Xsetup_0
Comment 6 Jack M. Nilles 2002-11-20 16:54:06 EST
I'm not sure what the vanilla 8.0 versioon should look like but I compared teh
file with its cousin on anotehr machine. The other machine had an additional
section on sysresouces. I copied this into the Xsetup_0 file on this machine,
logged out and logged in again. The usual results. I also tried "switchdesk KDE"
to get back into the GUI, but to no effect.

I am also surprised to see so many files in the rpm -aV output since this
machine has been scrupulously updated via up2date.
Comment 7 Jack M. Nilles 2002-11-25 19:26:33 EST
Upon further experimentation I find that redhat-config-date also doesn't work. I
get a series of error messages, to wit:
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'
Comment 8 Havoc Pennington 2002-12-19 19:12:18 EST
Jeremy have you heard of problems like this with upgrades?
Comment 9 Jeremy Katz 2002-12-19 19:20:30 EST
No, although the redhat-config-date traceback is a dupe of another that I filed
(and is fixed)
Comment 10 Havoc Pennington 2002-12-19 19:26:55 EST
I don't really have an idea where else to go on this report; we don't have any
similar reports, and it doesn't happen here.

Assuming some kind of local filesystem problem, or other strangeness... 

Note You need to log in before you can comment on or make changes to this bug.