Bug 77827 - redhat-config-xfree86 fails to detect hardware
Summary: redhat-config-xfree86 fails to detect hardware
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 03:58 UTC by Dan Swanwick
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-04 20:25:53 UTC


Attachments (Terms of Use)
/var/log/XFree86.setup.log from the failed run (1.28 KB, text/plain)
2002-11-14 12:12 UTC, Dan Swanwick
no flags Details

Description Dan Swanwick 2002-11-14 03:58:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
after moving a hard drive from one dell inspiron system to another,
redhat-config-xfree86 failed to correctly determine my hardware, and therefore
couldn't configure my system to start x.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Change system monitor or video card
2. Run redhat-config-xfree86
	

Actual Results:  redhat-config-xfree86 exited without provisionally starting x,
and therefore without allowing me to change settings to get a working x

Expected Results:  i should've been able to configure x

Additional info:

video card: ati rage 128 mobility; driver: r128
display: dell inspiron 1400x1050, 24 bit color

Comment 1 Alexander Larsson 2002-11-14 09:32:37 UTC
What did redhat-config-xfree86 print out on the command line, and please attach
the log (/var/log/XFree86.setup.log) to this bug.


Comment 2 Dan Swanwick 2002-11-14 12:13:00 UTC
Created attachment 85024 [details]
/var/log/XFree86.setup.log from the failed run

Comment 3 Dan Swanwick 2002-11-14 12:39:10 UTC
turns out it's 100% reproducible. all i had to do was move /etc/X11/XF86Config
to a different filename, quit x, and run the config program.

command line output:

[root@georgia root]# redhat-config-xfree86
*ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None

Couldn't start X server, trying with a fresh configuration
ID:   None
Name: None
HorizSync: None
VertSync:  None

Error, cannot start X server.

Comment 4 Alexander Larsson 2002-11-15 09:17:41 UTC
Strange. It doesn't find any modes. Since the DCC probe failed is should have
falled back to a SVGA monitor spec.

mharris: Exactly what does:
(EE) R128(0): No valid modes found
(EE) Screen(s) found, but none have a usable configuration.

Mean?


Comment 5 Brent Fox 2002-12-03 17:33:23 UTC
mharris: ping?

Comment 6 Mark Heslep 2003-02-22 11:02:35 UTC
I observe the same repeatable ddcprobe failure from ..config-xfree86 on my NEC
Multisync FP950 resulting in a fallback to 800x600, however:

A run of  'XFree86 -configure' correctly probes the monitor and produces a
correct /root/XF86config file up to the maximum supported resolution of the
nvidia driver.

Comment 7 Brent Fox 2003-05-27 19:41:27 UTC
Can you try with RHL 9 and see if the problem still exists?

Comment 8 Brent Fox 2003-09-04 20:25:53 UTC
Hmm, well, please reopen this bug is you can reproduce with RHL 9 or with the
Severn beta.  The r128 driver works fine for me with those two releses.

Comment 9 Dan Swanwick 2003-09-04 20:41:01 UTC
I'll upgrade at some point, and report back then. Thanks for following up.


Note You need to log in before you can comment on or make changes to this bug.