Bug 77836 - Pan 0.13 or higher locks up randomly
Pan 0.13 or higher locks up randomly
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: pan (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-14 03:55 EST by LWM
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-17 22:17:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LWM 2002-11-14 03:55:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
Pan 0.13 or higher crashes at random times under Gnome 2 and also under KDE 3,
though less often.  One can get a group listing from server, then pick a group,
and see the articles.  The lockup occurs when looking at the article listing or
reading an individual article.  It doesn't matter what group, or even if I
scroll through the listings with keyboard or mouse.  The fonts seem to melt into
one another, like a "line and a half" of garbled text.  Only thing that still
moves is the mouse...and ctrl+alt+bkspc will not work.  It happens EVERY time,
but only in RH 8 using all default settings for fonts, etc.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. launch Pan 0.13 or higher, get group listing from server.
2. pick any group...binaries seem to lock up even faster, at least sometimes.
3. scroll through the article headers...it takes from 1-30 minutes to lock.  
	

Actual Results:  Machine freezes totally except for tiny hard disk light
flickers and the mouse still moves.

Additional info: I think this is a GTK problem, to be honest.

This is a VIA CPU from Microtel...but I have not had this problem in Mandrake
9.0 or Debian and Pan 0.13.
Comment 1 Michael Lee Yohe 2002-11-14 10:37:39 EST
I use Pan exclusively (currently a self-rolled 0.13.2 package).  I do not have
this problem on either of the two machines I use Pan on (a dual P2-400 and a
P4-2400 box).  What video card are you using (since X appears to be the guy
that's not liking something on your machine)?
Comment 2 LWM 2002-11-14 12:50:57 EST
It's an NVidia Geforce 2 MX 200, 32 meg DDR.  Like I said, though I've never 
had this problem with anything except Redhat 8.  Mandrake 9.0 and Pan 0.13.x 
work great together, as does Debian Woody or whatever and Pan 0.13.x.  I would 
prefer to use Redhat, though...but Pan is important to me...enough so that I 
would switch from Redhat if I can't get this solved.  

It doesn't matter if I use "nv" or "nvidia" drivers, either.  Same thing 
happens.  Same thing happened WITHOUT the Nvidia card, too...same machine, 
just shared AGP Trident Cyberblade video.
Comment 3 Michael Lee Yohe 2002-11-14 12:56:49 EST
Is your machine up2date (latest kernel)?  You said that there is _some_ degree
of responsiveness to your system.  Can you ssh into your box after the freeze
and check the logs to see what is going on (a quick perusing of dmesg might tell
you something useful).  Also check your /var/log/XFree86.0.log file to see if
something is happening within X...

Report any strange result(s)...
Comment 4 LWM 2002-11-14 13:02:17 EST
No, there is no OS response at all when I try to SSH or telnet into the box.  
XFree86's log shows nothing out of the ordinary...no errors, nothing that 
would lead me to suspect any problems.  

The kernel is 2.4.18-16 I think (I'm not at that machine right now), but it's 
whatever kernel comes "out of the box" with Redhat 8.  I haven't changed a 
thing.  As long as I don't use Pan 0.13.x I'm ok...I don't notice any other 
app causing problems, though Mozilla 1.0 locked up once.  I have been told 
that this is a GTK2 problem and not Pan- or Redhat-specific, but I'm not yet 
sure.  Seems to only happen within Redhat 8.
Comment 5 LWM 2002-11-14 13:04:52 EST
BTW I reported this to bugzilla some few weeks ago, but thought I would try 
the more Redhat-specific route now.  Previous testing and observation are how 
I know about the nv vs. nvidia driver issue and the contents of XFree86 log 
files.  Already been though that, unfortunately.
Comment 6 Michael Lee Yohe 2002-11-14 13:11:28 EST
The latest version of the kernel is 2.4.18-17.8.0 - you may want to try that
kernel to address any issues that might trickle down the line, so to speak. 
Since Debian, Mandrake, etc. do not incorporate the enhancement features that
Red Hat includes with their kernel distribution - you may want to see if
something is inadvertantly affecting your system.

The reason I am so inquisitive is because I have RHL8 running on five different
machines (different processor types/configurations) and have experienced no
lockups or freezes, per se.

The next viable solution would be to get an mainstream, www.kernel.org, vanilla
kernel and see if your problems disappear.
Comment 7 LWM 2002-11-14 13:21:53 EST
I appreciate your help and advice.  I remember the first time I installed RH8 
I did upgrade the kernel via RHN to the latest available.  I have since 
reinstalled and gone back to the out-of-the-box kernel.  Just seems to me that 
if it were kernel-related it wouldn't just affect Pan.  Pan is the only 
program I run which uses GTK/GTK2, if I'm not mistaken.  I never had this 
problem with previous versions of Pan, either...just this one...which uses 
GTK2...and just on RH8.  I tried removing the Pan RPM from RH8 and compiling 
source from superpimp.org, per instruction from someone associated with 
bugzilla a week or so ago...but no change...even with the default GTK look and 
fonts, i.e., no RH8 enhancements.  If I could go back to RH7.3 I would...but I 
need 8.

When I get back to my other machine I might try a new kernel from kernel.org.
Comment 8 Jens Petersen 2002-11-14 20:25:41 EST
I also doubt it is pan, but have you tried any other versions (0.12.1 or
the newer 0.13.2 say)?
Comment 9 LWM 2002-11-15 02:12:24 EST
I think I've tried all versions of Pan, and as long as the version is 0.13 or
higher, it locks up.  Earlier versions didn't, even on Redhat 8.  I need 0.13
mainly for the binary decoding features, though.  So yes I've tried earlier and
later versions.
Comment 10 Jens Petersen 2002-11-16 23:17:18 EST
If you tried 0.12.x that is interesting, because that also uses gtk2,
but maybe it doesn't have the feature that is triggering the lockup
for you?
Comment 11 LWM 2002-11-16 23:31:28 EST
I don't *think* I've tried Pan 0.12.x because I was told that yEnc support was 
added in 0.13.x and that's what I really need from Pan in the first place.  
Right now things seem to be a bit more stable (read:  no crashes tonight) 
since I upgraded the kernel to the one mentioned in the RH errata.  I think it 
was 2.4.18.18, perhaps?  Again, I'm not on that machine at the moment.
Comment 12 Jens Petersen 2002-11-17 21:29:54 EST
Good the kernel errata seems to be making things more stable for you.
If you're no longer experience lockups, I guess this can can re-assigned
to the kernel component.
Comment 13 LWM 2002-11-17 22:16:55 EST
So far no lockups, but to be honest I think it's a combination of things.  The 
new kernel definitely helped but I also realized one more thing I didn't do on 
this install (I have re-installed RH 8 a total of 4 times now):  I didn't 
immediately download and install NVidia's driver for my Geforce 2.  I am using 
the RH 8 internal driver "nv" right now with success.  I know I said earlier I 
had tried that and had no success but I was mistaken...that was with Mandrake 
8.2 and a problem right after I got the Geforce card.  So as a test I will 
reinstall RH 8 tonight and do nothing except NOT use the NVidia driver...and 
try out Pan with the stock kernel and driver.  If it locks up, I will upgrade 
the kernel and try.  I want to use the NVidia driver because of h/w 
acceleration but if I can't I can't...I would rather have a stable OS.
Comment 14 Jens Petersen 2002-11-28 20:53:21 EST
As long as you know, using nvidia's driver is an unsupported
system configuration.  Closing for now.

Note You need to log in before you can comment on or make changes to this bug.