Bug 77840 - X hangs when moving or resizing Gnome terminal
X hangs when moving or resizing Gnome terminal
Status: CLOSED DUPLICATE of bug 73733
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-14 05:26 EST by Bert Coessens
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-14 19:41:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bert Coessens 2002-11-14 05:26:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
In a Gnome terminal window you can go up and down to text outside of the
terminal window using Ctrl-Page Up and Ctrl-Page Down. Resizing and moving the
terminal window is never a problem, but when I use Ctrl-Page Up to look at
previous commands and output in the terminal and after that (i.e. when the view
of the terminal does not show the prompt) I move or resize the terminal window,
my whole system hangs. I can't even reach the core shells anymore. All I can do
is push the reset button and make a fresh start.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Open a Gnome terminal
2.List a large directory (for instance ls /usr/bin)
3.Move upwards through the text using Ctrl-Page Up several times
4.Leave the view like that (no prompt visible)
5.Resize the window till the system halts
	

Additional info:
Comment 1 Bert Coessens 2002-11-14 05:31:42 EST
I tested it twice more and the crash is actually very reproducible.
Comment 2 Michael Lee Yohe 2002-11-14 10:35:17 EST
This is probably localized to your machine.  I've attempted to duplicate your
scenario on several RHL8 boxes and have been unable to do so.  Can you provide
some hardware specifications and note if your box is currently "up2date"?
Comment 3 Bert Coessens 2002-11-14 19:24:02 EST
Here are my specs:
Motherboard: Gigabyte GA7VAX KT400
Processor: AMD Duron 1.2 GHz
Linux kernel: 2.4.18-14 I did not upgrade to the 2.4.18-18
Video Card: AOpen nVIDIA Ge-Force II - MX400 (64 Mb)
I installed the latest version of the drivers provided by nVIDIA (kernel and GLX
driver: NVIDIA_GLX-1.0-3123.src.rpm and NVIDIA_kernel-1.0-3123.src.rpm). I had
to build from source because at this moment there are no drivers available for
RHL8.0.
Monitor: Panasonic PanaSunc S70 (this one is not in the list of available
monitors when installing RHL8.0)
Settings: HSync 31.5-48.5, VSync 50-70, resolution 1024x768

I actually had the halt right now when looking up my monitor specs, so it looks
like it is not limited to my gnome terminal... Again a hard reset is the only
way out.
Comment 4 Mike A. Harris 2002-11-14 19:41:43 EST
Dude, bluecurve is nothing more than a _theme_.  It's pretty pictures
basically, in the simplest sense.  Not sure exactly how you think a
*theme* is responsible for locking up your computer.

You've indicated you're using Nvidia's binary only drivers.  Red Hat
does not support Nvidia's binary drivers, nor do we ship them.  At this
point you should contact Nvidia technical support directly and report
this bug to them so that they can troubleshoot their driver and perhaps
fix the problem.
Comment 5 Mike A. Harris 2002-11-14 19:42:35 EST

*** This bug has been marked as a duplicate of 73733 ***

Note You need to log in before you can comment on or make changes to this bug.