Bug 77842 - RFE: add synaptics driver
RFE: add synaptics driver
Status: CLOSED DUPLICATE of bug 99351
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-14 06:12 EST by Michael Redinger
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2002-11-14 06:12:47 EST
The Synaptics Touchpad is used in many notebooks (Dell, Compaq, Sony Vaio etc.)

There's a good driver/config tool for it:
http://www.compass.com/synaptics/

Please include this in a future version.
Comment 1 Bill Nottingham 2002-11-14 12:56:38 EST
Hm, perhaps integrate this into redhat-config-mouse somehow?
Comment 2 Brent Fox 2002-12-16 12:30:14 EST
michael: I'm not sure what you're asking for.  Do the Synaptics touchpads work
at all with Linux?  
Comment 3 Michael Redinger 2002-12-18 14:13:44 EST
The Synaptics toucpads work fine under Linux. This is an RFE: the Synaptics
TouchPad Driver includes many nice features.

See http://www.mobilix.org/touchpad_driver.html for a summary.

Comment 4 Brent Fox 2002-12-23 01:08:09 EST
redhat-config-mouse is mainly in the business of modifying the
/etc/sysconfig/mouse and /etc/X11/XF86Config files.  It's job isn't really to
provide mouse drivers.  I'm going to change the component to 'distribution' to
see if anybody else knows who would need to make the call on this.  mharris maybe?
Comment 5 Brent Fox 2002-12-23 01:11:58 EST
oops, notting.  I didn't mean to assign it right back to you.  It looks like
this driver wants to be installed in /usr/X11R6/lib/modules/input, so I'm
guessing that including the driver is really mharris' call.  Changing component
to XFree86.
Comment 6 Mike A. Harris 2002-12-29 03:47:39 EST
The synaptics driver at the URL above is GPL licensed, which means that it
is not acceptable for inclusion in XFree86 source code base, as all code must
be under an MIT or similar license.  It's rather a shame that it was GPL
licensed and not just MIT licensed, otherwise it could have been submitted
to XFree86.org and included directly in X sources.

"This software is made available under the  GPL license."

I do not have any synaptics hardware here personally, so I can not test nor
debug any problems with the synaptics driver.  If it were to be included,
it would have to be included as a separate RPM package.  If someone at
Red Hat has this hardware and is willing to test this driver, and maintain
the driver package, I have no objection to it being added to the distribution.


Comment 7 Mike A. Harris 2003-01-24 18:18:44 EST
Defering for future consideration
Comment 8 Mike A. Harris 2003-09-09 18:25:18 EDT

*** This bug has been marked as a duplicate of 99351 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:50:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.