Bug 7785 - ping -c 1 does not exit after 1 packet sent
ping -c 1 does not exit after 1 packet sent
Status: CLOSED DUPLICATE of bug 8724
Product: Red Hat Linux
Classification: Retired
Component: netkit-base (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-13 05:58 EST by bmisener
Modified: 2016-03-10 11:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-27 15:06:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bmisener 1999-12-13 05:58:27 EST
Many packages use ping to test to see if a machine is alive.
The ping -c 1 hostname  is executed and the return code checked.
Normally this command would send out 1 packet , wait to see if it
returns, and exit after the wait time since its only to send 1 packet.
This command is not exiting - it is continueing to send packets and
never exiting. WHen the command is given a ctrl-c at the command line
it then indicates it has sent more than the proper number of packets.

[root@stealth /root]# ping -c 1 cad609
PING cad609.cad.dehavilland.ca (134.31.80.236) from 134.31.40.45 : 56(84)
bytes of data.

--- cad609.cad.dehavilland.ca ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
[root@stealth /root]#


The command above was given a ctrl-c after about 20 seconds....
Comment 1 Todd Knauer 2000-01-22 17:42:59 EST
I have also come to the same conclusion.  I run several Big Brother Server on
various platforms (Solaris 2.5.1 SPARC) and RedHat 5.2 i386.  I set up a
BigBrother server on RedHat 6.0 i386 at another company and it ran for a few
days without any apparent problems until a router went down for a very short
period of time.

The "ping -c 1 xxx.xxx.xxx.xxx" never returned control and everything went
purple until the box was rebooted.  I worked on this for a few days before
figuring out exactly where the problem was.

In addition I can not seem to "traceroute xxx.xxx.xxx.xxx" to any of the router
interfaces (it will traceroute to a server behind the remote routers, a Windows
machine on the same hub can traceroute to the routers just fine.

I upgraded to RedHat 6.1 and the same problem exists. I even compiled and
installed "fping" but it has the same problem so I assume it is an underlying
problem with a library or the kernel.

My next step is to install Mandrake or some other package (or even RedHat 5.2
which might be the better choice as I have had no trouble with it at the other
location).

This bug list is the first time I've seen any other references to the problem
(other than someone on the Big Brother mailing list mentioned it in one
message).

Thanks,
Todd
Comment 2 Todd Knauer 2000-01-22 18:04:59 EST
In fact, try this: "ping -c 1 12.10.0.6".  I don't know who's address it is but
you certainly can duplicate that ping does not return (I just picked an address
out of the air and just so happened exhibited the problem).
Comment 3 Jeff Johnson 2000-01-27 15:06:59 EST
*** This bug has been marked as a duplicate of 8724 ***
Comment 4 openshift-github-bot 2016-03-10 11:54:24 EST
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/1df7eccd4c62b7cd1639202fac9c73b3cb40bc7d
Merge pull request #7794 from soltysh/issue7785

Merged by openshift-bot

Note You need to log in before you can comment on or make changes to this bug.