Bug 778536 - (SOA-1008) Introduce jbpm deployer
Introduce jbpm deployer
Status: CLOSED WONTFIX
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, JBPM - within SOA, Deployment (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 5.0.0 GA
Assigned To: Default User
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 05:20 EST by Bernd Ruecker
Modified: 2010-01-22 12:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 12:23:20 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-1008 None Closed Introduce jbpm deployer 2012-01-17 09:58:28 EST

  None (edit)
Description Bernd Ruecker 2008-11-14 05:20:10 EST
Date of First Response: 2008-11-14 05:23:03
project_key: SOA

In the AS/ESB environment, and especially in the JBoss SAO platform a jbpm deployer would be a nice feature.

The deployer can pick up process archives (par) like other deployers do and deploy these processes to jbpm (hence in the jbpm database). 

One additional feature which make sense in my eyes is to also support scoped classloading. In jbpm 3 you can use the configurable ProcessClassLoader to implement the desired behavior.

I sketched the ideas in these two blogging entries, the solution is working at the current project without problems:
- http://www.bpm-guide.de/2008/10/16/jbpm-deployer-for-jbpm-in-enterprise-environments/
- http://www.bpm-guide.de/2008/11/14/jbpm-deployer-status-and-sourcecode/

In the jbpm team the solution was discussed last week on the meeting, and it was somehow agreed on, that the same behavior should be included in jbpm 4 from the start.
Comment 1 Kevin Conner 2008-11-14 05:23:03 EST
This would be a great addition to the jBPM project, making it a first class resource within the app server. :)
Comment 2 Thomas Diesler 2008-11-17 02:33:49 EST
Thanks I'll take a look
Comment 3 Thomas Diesler 2008-12-15 04:00:46 EST
Resolved as part of [JBPM-1883] and [JBPM-1884]
Comment 4 Bernd Ruecker 2009-01-07 09:04:04 EST
Hi Thomas! I am a bit confused about the status now. 
What I found in the codebase was a "Deployment" interface and a DeploymenService in "the API".

But how is it included in the ESB? Unfortunately there are no fisheye links to code. And somewhere needs to be a JBoss AS Deployer, right? Is it only targeted for jbpm 4? Then it couldn't go into JBoss ESB 4.3 already, right?

Can you quickly explain? Thanks a lot for sheding light on this...
Comment 5 Jiri Pechanec 2010-01-05 04:14:05 EST
I do not see SOA-P 5 ER6 configured to support deployment of par files
Comment 6 Kevin Conner 2010-01-05 05:45:28 EST
I don't think this should have been marked as Done in the first place, as no integration of this has ever taken place.
Comment 7 Thomas Diesler 2010-01-06 23:44:45 EST
Unassigned myself - could you please discuss this with the jBPM team?

In 2008 we had long dicusions on whether a jbpm deployer was needed or not.
The last I heard was that a deployer was rejected. Instead they preferred to deploy a servlet that installs a process definition directly into the jBPM runtime bypassing the jboss deployer architechture.
Comment 8 Kevin Conner 2010-01-07 02:01:52 EST
As far as I am aware this was discussed at length with the jBPM team and, from the earlier comments on this issue (and JBPM-1883/JBPM-1884), this work should already have been done.

If this is not the case then we need to correct the comments on this case *and* reopen both of those issues.

What appears to be missing is the configuration (and testing of course) of this new deployer within SOA.

Comment 9 Tom Baeyens 2010-01-07 05:07:32 EST
afaict, there has not been a promise to the soa platform productization to deliver a jboss deployer for par files.   this would have to be discussed at lenght before because it is has a lot of implications.  synchronizing pars in a deploy directory with deployments in a jbpm database has a lot of situations that can go bad.   writing a jboss deployer that finds and deploys a par file is easy.  but how to know at server boot time if a process needs to be redeployed ?  how to sync in a cluster?  what if the deployment is deleted in jbpm?... etc.  all those requirements have to be discussed and agreed before we can go ahead with this.
Comment 10 Kevin Conner 2010-01-07 05:14:37 EST
Yep, I remember having long discussions with you about this :)

Might be a good idea to reopen the JBPM issues in this case, as the work was obviously not done.  This does beg the question as to what *was* done though :)
Comment 11 Bernd Ruecker 2010-01-11 02:45:56 EST
I think this issue is really an interessting one. But I would really like to come to a conclusion, that satisfies the main use cases. First we have to sketch the different lifecycles and an idea how to solve it. I could go ahead with it and propose an idea, I created: JBPM-2743
Comment 12 Burr Sutter 2010-01-22 12:23:20 EST
We do not believe this particular feature is vital for jBPM3 inside of SOA4.3/5.0.   It can be looked at again for jBPM4 at some future date.
Process Deployment is currently handled via JBDS/Tools, the console and via ant task.
Comment 13 tbf 2010-01-22 12:37:54 EST
Deploying via JBDS/Tools is not an option for production environments (if many processes are involved and changes to these also depend on changes in ESB services/other applications), or at least it would be a tedious (and most likely error prone) process.

The ant deployment requires the server to run. There is no way to provision an entire set of changes for instance via Red Hat Satellite (and no way to do a complete software update of a given system without the extra step of deploying the jBPM processes after the system is started as a separate task). jBPM is still a fairly technical tool. Letting business users deploy processes and classes using Eclipse directly without something like BRMS to help with testing etc. is often not realistic.

Note You need to log in before you can comment on or make changes to this bug.