Bug 77859 - openssh needs /usr/X11/bin for x forwarded authentication
openssh needs /usr/X11/bin for x forwarded authentication
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-14 09:38 EST by R P Herrold
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 05:39:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-11-14 09:38:52 EST
The first example gets authentication going -- the second needs the path to get
authentication going (the second is the how it is compiled presently)


[herrold@oldnews .ssh]$ ssh -t dell4.emscorporate.com PATH="$PATH:/usr/X11/bin"
ksirc --server irc.inside.lan

_KDE_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
DCOPServer up and running.
mcop warning: user defined signal handler found for SIG_PIPE, overriding
Mutex destroy failure: Device or resource busy
kdeinit: Fatal IO error: client killed
kdeinit: sending SIGHUP to children.
kdeinit: sending SIGTERM to children.
kdeinit: Exit.
Connection to dell4.emscorporate.com closed.

[herrold@oldnews .ssh]$ ssh -t dell4.emscorporate.com ksirc --server irc.inside.lan

_KDE_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
sh: iceauth: command not found
ICE Connection rejected!

DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None
of the authentication protocols specified are supported and host-based
authentication failed
ICE Connection rejected!

DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None
of the authentication protocols specified are supported and host-based
authentication failed
DCOPServer self-test failed.
sh: iceauth: command not found
kdeinit: DCOPServer could not be started, aborting.
Comment 1 Tomas Mraz 2005-02-04 05:39:52 EST
Cannot reproduce on the current Fedora Core.

Note You need to log in before you can comment on or make changes to this bug.